summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhugovk <hugovk@gmail.com>2019-02-06 20:14:54 +0000
committerhugovk <hugovk@gmail.com>2019-02-06 20:14:54 +0000
commit6250ccc494d88412ce7570e33fce9d8639935457 (patch)
tree1f7e72114ec915b8c223f3255cafd3a827ef2049
parent564b072c8d0d3c40563fa1a416b58221d71d0bff (diff)
downloadpygments-6250ccc494d88412ce7570e33fce9d8639935457.tar.gz
Add python_requires and update Trove classifiers
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3f75a20e..52889227 100755
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,7 @@ setup(
platforms = 'any',
zip_safe = False,
include_package_data = True,
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
classifiers = [
'License :: OSI Approved :: BSD License',
'Intended Audience :: Developers',
@@ -68,7 +69,11 @@ setup(
'Development Status :: 6 - Mature',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Operating System :: OS Independent',
'Topic :: Text Processing :: Filters',
'Topic :: Utilities',