summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2014-09-20 21:21:39 +0200
committerGeorg Brandl <georg@python.org>2014-09-20 21:21:39 +0200
commit1d5318fb4b53f57660427e228db5061c4a656c13 (patch)
tree71c9af18e9283ea9ea18b102c93553e994f04c70
parent16213200290b7d9d09396550cae75a91b3658572 (diff)
downloadpygments-1d5318fb4b53f57660427e228db5061c4a656c13.tar.gz
Update the "intro" blurb a bit, and add a few missing links to the main doc page.
-rw-r--r--README.rst6
-rw-r--r--doc/conf.py2
-rw-r--r--doc/index.rst23
-rwxr-xr-xsetup.py11
4 files changed, 21 insertions, 21 deletions
diff --git a/README.rst b/README.rst
index 1908db1e..e6c03926 100644
--- a/README.rst
+++ b/README.rst
@@ -1,9 +1,9 @@
README for Pygments
===================
-This is the source of Pygments. It is a generic syntax highlighter for general use
-in all kinds of software such as forum systems, wikis or other applications that
-need to prettify source code.
+This is the source of Pygments. It is a generic syntax highlighter that
+supports over 300 languages and text formats, for use in code hosting, forums,
+wikis or other applications that need to prettify source code.
Installing
----------
diff --git a/doc/conf.py b/doc/conf.py
index 864ec7a1..4ac487fa 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -117,7 +117,7 @@ html_theme_path = ['_themes']
# The name of an image file (within the static path) to use as favicon of the
# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
# pixels large.
-html_favicon = 'favicon.ico'
+html_favicon = '_static/favicon.ico'
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
diff --git a/doc/index.rst b/doc/index.rst
index a0e41210..26114045 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -1,20 +1,21 @@
Welcome!
========
-This is the home of Pygments. It is a generic syntax highlighter for general use
-in all kinds of software such as forum systems, wikis or other applications that
-need to prettify source code. Highlights are:
+This is the home of Pygments. It is a generic syntax highlighter suitable for
+use in code hosting, forums, wikis or other applications that need to prettify
+source code. Highlights are:
-* a wide range of common languages and markup formats is supported
+* a wide range of over 300 languages and other text formats is supported
* special attention is paid to details that increase highlighting quality
-* support for new languages and formats are added easily; most languages use a simple regex-based lexing mechanism
-* a number of output formats is available, among them HTML, RTF, LaTeX and ANSI sequences
+* support for new languages and formats are added easily; most languages use a
+ simple regex-based lexing mechanism
+* a number of output formats is available, among them HTML, RTF, LaTeX and ANSI
+ sequences
* it is usable as a command-line tool and as a library
-* ... and it highlights even Brainf*ck!
+* ... and it highlights even Perl 6!
-Read more in the FAQ list or the documentation, or download the latest release.
-
-Though Pygments has not yet won an award, we trust that you will notice it's a top quality product <wink>.
+Read more in the :doc:`FAQ list <faq>` or the :doc:`documentation <docs/index>`,
+or `download the latest release <http://pypi.python.org/pypi/Pygments>`_.
.. _contribute:
@@ -45,7 +46,7 @@ Pygments is maintained by **Georg Brandl**, e-mail address *georg*\ *@*\ *python
Many lexers and fixes have been contributed by **Armin Ronacher**, the rest of
the `Pocoo <http://dev.pocoo.org/>`_ team and **Tim Hatch**.
-
+
.. toctree::
:maxdepth: 1
:hidden:
diff --git a/setup.py b/setup.py
index 5565adef..3d32c539 100755
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,15 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-"""
- Pygments
+"""Pygments
~~~~~~~~
Pygments is a syntax highlighting package written in Python.
- It is a generic syntax highlighter for general use in all kinds of software
- such as forum systems, wikis or other applications that need to prettify
- source code. Highlights are:
+ It is a generic syntax highlighter suitable for use in code hosting, forums,
+ wikis or other applications that need to prettify source code. Highlights
+ are:
- * a wide range of common languages and markup formats is supported
+ * a wide range of over 300 languages and other text formats is supported
* special attention is paid to details, increasing quality by a fair amount
* support for new languages and formats are added easily
* a number of output formats, presently HTML, LaTeX, RTF, SVG, all image \