summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2017-01-22 22:04:28 +0100
committerGeorg Brandl <georg@python.org>2017-01-22 22:04:28 +0100
commit77ff159528222b8cf182d6762cc1c7d9fc71151c (patch)
treecfb580deecd4f206e60a0be3a0e11addbdebcbe9
parenta82f7a4953bcbc16813b18d761d91dd215149c0d (diff)
downloadpygments-77ff159528222b8cf182d6762cc1c7d9fc71151c.tar.gz
Bump to 2.2.0 final.2.2.0
-rw-r--r--CHANGES6
-rw-r--r--MANIFEST.in2
-rw-r--r--pygments/__init__.py2
-rwxr-xr-xsetup.py4
4 files changed, 7 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index 9a85ac27..0bab9118 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,9 +6,9 @@ Issue numbers refer to the tracker at
pull request numbers to the requests at
<https://bitbucket.org/birkenfeld/pygments-main/pull-requests/merged>.
-Version 2.2
------------
-(in development)
+Version 2.2.0
+-------------
+(release Jan 22, 2017)
- Added lexers:
diff --git a/MANIFEST.in b/MANIFEST.in
index cfec4e94..7e1d320d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,6 +1,6 @@
include pygmentize
include external/*
-include Makefile CHANGES LICENSE AUTHORS TODO ez_setup.py
+include Makefile CHANGES LICENSE AUTHORS TODO
recursive-include tests *
recursive-include doc *
recursive-include scripts *
diff --git a/pygments/__init__.py b/pygments/__init__.py
index cc238e02..394a85f2 100644
--- a/pygments/__init__.py
+++ b/pygments/__init__.py
@@ -29,7 +29,7 @@ import sys
from pygments.util import StringIO, BytesIO
-__version__ = '2.2a0'
+__version__ = '2.2.0'
__docformat__ = 'restructuredtext'
__all__ = ['lex', 'format', 'highlight']
diff --git a/setup.py b/setup.py
index 5ef51ab5..1705923c 100755
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ else:
setup(
name = 'Pygments',
- version = '2.2',
+ version = '2.2.0',
url = 'http://pygments.org/',
license = 'BSD License',
author = 'Georg Brandl',
@@ -56,7 +56,7 @@ setup(
description = 'Pygments is a syntax highlighting package written in Python.',
long_description = __doc__,
keywords = 'syntax highlighting',
- packages = find_packages(exclude=['ez_setup']),
+ packages = find_packages(),
platforms = 'any',
zip_safe = False,
include_package_data = True,