summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2014-10-07 14:55:10 +0200
committerGeorg Brandl <georg@python.org>2014-10-07 14:55:10 +0200
commitb977e2e3e21e64a758bf35acfe38fc47158e38b5 (patch)
treeae99289fe2ab1c740b2716a14ba16e6ae4678fda /Makefile
parent04a8a0ce203ed66b70415dca03bf74bc983ef822 (diff)
downloadpygments-b977e2e3e21e64a758bf35acfe38fc47158e38b5.tar.gz
Add a pyflakes run to "make check".
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 35814160..020f6acd 100644
--- a/Makefile
+++ b/Makefile
@@ -19,6 +19,7 @@ all: clean-pyc check test
check:
@$(PYTHON) scripts/detect_missing_analyse_text.py || true
+ @pyflakes pygments | grep -v 'but unused' || true
@$(PYTHON) scripts/check_sources.py -i build -i dist -i pygments/lexers/_mapping.py \
-i docs/build -i pygments/formatters/_mapping.py -i pygments/unistring.py