summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorgbrandl <devnull@localhost>2007-02-18 15:40:55 +0100
committergbrandl <devnull@localhost>2007-02-18 15:40:55 +0100
commit4f20affc8e7133fc897c754ea8d5ef403ab44399 (patch)
tree6f0f860be85a6be739b3f6683139dc93e84de7fd /Makefile
parentfd77019bad3bc2f829a83b25e75cf61ddcc544a1 (diff)
downloadpygments-4f20affc8e7133fc897c754ea8d5ef403ab44399.tar.gz
[svn] Add a new test for pygments.util, fix coverage test.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 59677630..86fd4b24 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ PYTHON ?= python
export PYTHONPATH = $(shell echo "$$PYTHONPATH"):$(shell python -c 'import os; print ":".join(os.path.abspath(line.strip()) for line in file("PYTHONPATH"))' 2>/dev/null)
.PHONY: all apidocs check clean clean-pyc codetags docs epydoc mapfiles \
- pylint reindent test
+ pylint reindent test test-coverage
all: clean-pyc check test
@@ -68,3 +68,6 @@ reindent:
test:
@$(PYTHON) tests/run.py $(TESTS)
+
+test-coverage:
+ @$(PYTHON) tests/run.py -C $(TESTS)