summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2018-11-25 08:37:32 +0100
committerGeorg Brandl <georg@python.org>2018-11-25 08:37:32 +0100
commit6866f8b98f4051603b560e6f6313b74eee7a12a9 (patch)
treeb9fede197239933d0b9bc6fda0030c70d281eb03 /Makefile
parent67ca36ddb9b8b00c9158db00fcb3e10bd6e78c58 (diff)
downloadpygments-6866f8b98f4051603b560e6f6313b74eee7a12a9.tar.gz
Minimal fixup changes for the release, add release date.2.3.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 82c4a124..878b94b7 100644
--- a/Makefile
+++ b/Makefile
@@ -63,3 +63,9 @@ tox-test:
tox-test-coverage:
@tox -- --with-coverage --cover-package=pygments --cover-erase $(TEST)
+
+RLMODULES = pygments.lexers
+
+regexlint:
+ @if [ -z "$(REGEXLINT)" ]; then echo "Please set REGEXLINT=checkout path"; exit 1; fi
+ PYTHONPATH=`pwd`:$(REGEXLINT) $(REGEXLINT)/regexlint/cmdline.py $(RLMODULES)