summaryrefslogtreecommitdiff
path: root/pygments/lexers/shell.py
diff options
context:
space:
mode:
authorKaleb Elwert <belak@coded.io>2016-08-18 16:21:09 -0700
committerKaleb Elwert <belak@coded.io>2016-08-18 16:21:09 -0700
commit8e05673f8986144087bc7a280308929327e88641 (patch)
treea59748ab6b4df09928ca4e3822dbc6893e5e78d6 /pygments/lexers/shell.py
parent421263e90981c08119640d280af96550e9f5fd05 (diff)
downloadpygments-8e05673f8986144087bc7a280308929327e88641.tar.gz
Highlight zsh files using the BashLexer
Diffstat (limited to 'pygments/lexers/shell.py')
-rw-r--r--pygments/lexers/shell.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/pygments/lexers/shell.py b/pygments/lexers/shell.py
index a5933afb..752e71a7 100644
--- a/pygments/lexers/shell.py
+++ b/pygments/lexers/shell.py
@@ -27,16 +27,17 @@ line_re = re.compile('.*?\n')
class BashLexer(RegexLexer):
"""
- Lexer for (ba|k|)sh shell scripts.
+ Lexer for (ba|k|z|)sh shell scripts.
.. versionadded:: 0.6
"""
name = 'Bash'
- aliases = ['bash', 'sh', 'ksh', 'shell']
+ aliases = ['bash', 'sh', 'ksh', 'zsh', 'shell']
filenames = ['*.sh', '*.ksh', '*.bash', '*.ebuild', '*.eclass',
- '*.exheres-0', '*.exlib',
- '.bashrc', 'bashrc', '.bash_*', 'bash_*', 'PKGBUILD']
+ '*.exheres-0', '*.exlib', '*.zsh',
+ '.bashrc', 'bashrc', '.bash_*', 'bash_*', 'zshrc', '.zshrc',
+ 'PKGBUILD']
mimetypes = ['application/x-sh', 'application/x-shellscript']
tokens = {