summaryrefslogtreecommitdiff
path: root/pygments/lexers
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2010-03-01 16:21:33 +0100
committerGeorg Brandl <georg@python.org>2010-03-01 16:21:33 +0100
commitbac7edec4fadebbf80b1d4306da841a50095695f (patch)
tree5688e40d109676fc9407e1bff784e5a687b0c6e7 /pygments/lexers
parent0ed2f03a5153ece9b20ef5644944f88071b462ee (diff)
downloadpygments-bac7edec4fadebbf80b1d4306da841a50095695f.tar.gz
#469: use bash lexer for .ksh scripts.
Diffstat (limited to 'pygments/lexers')
-rw-r--r--pygments/lexers/_mapping.py2
-rw-r--r--pygments/lexers/other.py6
2 files changed, 4 insertions, 4 deletions
diff --git a/pygments/lexers/_mapping.py b/pygments/lexers/_mapping.py
index 12778c88..f90251d0 100644
--- a/pygments/lexers/_mapping.py
+++ b/pygments/lexers/_mapping.py
@@ -32,7 +32,7 @@ LEXERS = {
'AsymptoteLexer': ('pygments.lexers.other', 'Asymptote', ('asy', 'asymptote'), ('*.asy',), ('text/x-asymptote',)),
'BBCodeLexer': ('pygments.lexers.text', 'BBCode', ('bbcode',), (), ('text/x-bbcode',)),
'BaseMakefileLexer': ('pygments.lexers.text', 'Makefile', ('basemake',), (), ()),
- 'BashLexer': ('pygments.lexers.other', 'Bash', ('bash', 'sh'), ('*.sh', '*.ebuild', '*.eclass'), ('application/x-sh', 'application/x-shellscript')),
+ 'BashLexer': ('pygments.lexers.other', 'Bash', ('bash', 'sh', 'ksh'), ('*.sh', '*.ksh', '*.bash', '*.ebuild', '*.eclass'), ('application/x-sh', 'application/x-shellscript')),
'BashSessionLexer': ('pygments.lexers.other', 'Bash Session', ('console',), ('*.sh-session',), ('application/x-shell-session',)),
'BatchLexer': ('pygments.lexers.other', 'Batchfile', ('bat',), ('*.bat', '*.cmd'), ('application/x-dos-batch',)),
'BefungeLexer': ('pygments.lexers.other', 'Befunge', ('befunge',), ('*.befunge',), ('application/x-befunge',)),
diff --git a/pygments/lexers/other.py b/pygments/lexers/other.py
index f89e7502..1df41830 100644
--- a/pygments/lexers/other.py
+++ b/pygments/lexers/other.py
@@ -321,14 +321,14 @@ class BefungeLexer(RegexLexer):
class BashLexer(RegexLexer):
"""
- Lexer for (ba)sh shell scripts.
+ Lexer for (ba|k|)sh shell scripts.
*New in Pygments 0.6.*
"""
name = 'Bash'
- aliases = ['bash', 'sh']
- filenames = ['*.sh', '*.ebuild', '*.eclass']
+ aliases = ['bash', 'sh', 'ksh']
+ filenames = ['*.sh', '*.ksh', '*.bash', '*.ebuild', '*.eclass']
mimetypes = ['application/x-sh', 'application/x-shellscript']
tokens = {