summaryrefslogtreecommitdiff
path: root/scripts/release-checklist
diff options
context:
space:
mode:
authorMauricio Caceres Bravo <mauricio.caceres.bravo@gmail.com>2019-02-12 10:27:34 -0500
committerMauricio Caceres Bravo <mauricio.caceres.bravo@gmail.com>2019-02-12 10:27:34 -0500
commit62ff49874c8a405fc24a83cb6611e8a5cf818bd5 (patch)
tree8b33912d57eb8bedcc75f30f146608ea59f43e8a /scripts/release-checklist
parentdf656b31ecabd8a1b649f79de050854a2974e395 (diff)
parent77e24d5ab193f6c3fa8492f5410a2e841f9ebfad (diff)
downloadpygments-62ff49874c8a405fc24a83cb6611e8a5cf818bd5.tar.gz
Merged default branch to hopefully solve merge conflicts
Diffstat (limited to 'scripts/release-checklist')
-rw-r--r--scripts/release-checklist24
1 files changed, 24 insertions, 0 deletions
diff --git a/scripts/release-checklist b/scripts/release-checklist
new file mode 100644
index 00000000..efc1e1e8
--- /dev/null
+++ b/scripts/release-checklist
@@ -0,0 +1,24 @@
+Release checklist
+=================
+
+* Check ``hg status``
+* ``make check``
+* LATER when configured properly: ``make pylint``
+* ``tox``
+* Update version info in ``setup.py/__init__.py``
+* Check setup.py metadata: long description, trove classifiers
+* Update release date/code name in ``CHANGES``
+* ``hg commit``
+* ``make clean``
+* ``python2 setup.py release bdist_wheel``
+* ``python3 setup.py release bdist_wheel sdist``
+* ``twine upload dist/Pygments-$NEWVER*``
+* Check PyPI release page for obvious errors
+* ``hg tag``
+* Merge default into stable if this was a ``x.y.0``
+* Update homepage (release info), regenerate docs (+printable!)
+* Add new version/milestone to tracker categories
+* Write announcement and send to mailing list/python-announce
+* Update version info, add new ``CHANGES`` entry for next version
+* ``hg commit``
+* ``hg push``