summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorgbrandl <devnull@localhost>2009-03-31 10:26:55 -0500
committergbrandl <devnull@localhost>2009-03-31 10:26:55 -0500
commit7b95efab48d9ec79e995bf4d6db10fd049e3395a (patch)
tree48fc9b840dab83976a85af85d1c705dbaa051a0b /setup.py
parentf12c878ed096137c91658a0f62f0070e08c2afea (diff)
downloadpygments-7b95efab48d9ec79e995bf4d6db10fd049e3395a.tar.gz
Port Pygments to Python 3.1.
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py66
1 files changed, 49 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index dde01272..de3f69af 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,29 +1,60 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-import ez_setup
-ez_setup.use_setuptools()
-from setuptools import setup, find_packages
+"""
+ Pygments
+ ~~~~~~~~
-import pygments
+ Pygments is a syntax highlighting package written in Python.
-author, email = pygments.__author__[:-1].split(' <')
+ It is a generic syntax highlighter for general use in all kinds of software
+ such as forum systems, wikis or other applications that need to prettify
+ source code. Highlights are:
+
+ * a wide range of common languages and markup formats is supported
+ * special attention is paid to details, increasing quality by a fair amount
+ * support for new languages and formats are added easily
+ * a number of output formats, presently HTML, LaTeX, RTF, SVG and ANSI sequences
+ * it is usable as a command-line tool and as a library
+ * ... and it highlights even Brainfuck!
+
+ The `Pygments tip`_ is installable with ``easy_install Pygments==dev``.
+
+ .. _Pygments tip: http://dev.pocoo.org/hg/pygments-main/archive/tip.tar.gz#egg=Pygments-dev
+
+ :copyright: Copyright 2006-2009 by the Pygments team, see AUTHORS.
+ :license: BSD, see LICENSE for details.
+"""
+
+try:
+ from setuptools import setup, find_packages
+except ImportError:
+ from distutils.core import setup
+ def find_packages():
+ return [
+ 'pygments',
+ 'pygments.lexers',
+ 'pygments.formatters',
+ 'pygments.styles',
+ 'pygments.filters',
+ ]
+
+try:
+ from distutils.command.build_py import build_py_2to3 as build_py
+except ImportError:
+ from distutils.command.build_py import build_py
setup(
name = 'Pygments',
- version = pygments.__version__,
- url = pygments.__url__,
- license = pygments.__license__,
- author = author,
- author_email = email,
+ version = '1.1',
+ url = 'http://pygments.org/',
+ license = 'BSD License',
+ author = 'Georg Brandl',
+ author_email = 'georg@python.org',
description = 'Pygments is a syntax highlighting package written in Python.',
- long_description = pygments.__doc__,
+ long_description = __doc__,
keywords = 'syntax highlighting',
packages = find_packages(),
- entry_points = {
- 'console_scripts': [
- 'pygmentize = pygments.cmdline:main',
- ],
- },
+ scripts = ['pygmentize'],
platforms = 'any',
zip_safe = False,
include_package_data = True,
@@ -35,5 +66,6 @@ setup(
'Development Status :: 5 - Production/Stable',
'Programming Language :: Python',
'Operating System :: OS Independent',
- ]
+ ],
+ cmdclass = {'build_py': build_py},
)