summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--LICENSE46
-rw-r--r--TODO14
-rw-r--r--docs/generate.py2
-rw-r--r--pygments/__init__.py4
-rw-r--r--pygments/console.py2
-rw-r--r--pygments/formatter.py2
-rw-r--r--pygments/formatters/__init__.py2
-rw-r--r--pygments/formatters/bbcode.py2
-rw-r--r--pygments/formatters/html.py2
-rw-r--r--pygments/formatters/latex.py2
-rw-r--r--pygments/formatters/other.py2
-rw-r--r--pygments/formatters/terminal.py2
-rw-r--r--pygments/lexer.py2
-rw-r--r--pygments/lexers/__init__.py2
-rw-r--r--pygments/lexers/_luabuiltins.py2
-rw-r--r--pygments/lexers/_mapping.py2
-rw-r--r--pygments/lexers/_phpbuiltins.py2
-rw-r--r--pygments/lexers/agile.py4
-rw-r--r--pygments/lexers/compiled.py2
-rw-r--r--pygments/lexers/dotnet.py2
-rw-r--r--pygments/lexers/other.py2
-rw-r--r--pygments/lexers/special.py2
-rw-r--r--pygments/lexers/templates.py2
-rw-r--r--pygments/lexers/text.py2
-rw-r--r--pygments/lexers/web.py2
-rw-r--r--pygments/plugin.py2
-rw-r--r--pygments/scanner.py2
-rw-r--r--pygments/style.py2
-rw-r--r--pygments/styles/__init__.py2
-rw-r--r--pygments/styles/autumn.py2
-rw-r--r--pygments/styles/borland.py2
-rw-r--r--pygments/styles/colorful.py2
-rw-r--r--pygments/styles/default.py2
-rw-r--r--pygments/styles/friendly.py2
-rw-r--r--pygments/styles/manni.py8
-rw-r--r--pygments/styles/murphy.py2
-rw-r--r--pygments/styles/native.py2
-rw-r--r--pygments/styles/pastie.py2
-rw-r--r--pygments/styles/perldoc.py2
-rw-r--r--pygments/styles/trac.py2
-rw-r--r--pygments/token.py2
-rw-r--r--pygments/util.py2
-rwxr-xr-xscripts/check_sources.py2
-rw-r--r--scripts/find_abandoned_lexers.py2
-rw-r--r--scripts/vim2pygments.py2
-rw-r--r--setup.py2
-rw-r--r--tests/test_basic_api.py2
-rw-r--r--tests/test_clexer.py2
-rw-r--r--tests/test_cmdline.py2
-rw-r--r--tests/test_examplefiles.py2
51 files changed, 89 insertions, 79 deletions
diff --git a/CHANGES b/CHANGES
index 030c1456..90398a3c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -5,6 +5,8 @@ Version 0.6
-----------
(released Dec XX, 2006)
+- License change to BSD.
+
- Added a Scheme lexer (thanks to Marek Kubica).
- Added some functions to iterate over existing lexers, formatters
diff --git a/LICENSE b/LICENSE
index 76f95fdc..687b8482 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,16 +1,30 @@
-Pygments - Python syntax highlighting package
-Copyright (C) 2006 by the respective authors (see AUTHORS)
-
-This library is free software; you can redistribute it and/or
-modify it under the terms of the GNU Lesser General Public
-License as published by the Free Software Foundation; either
-version 2.1 of the License, or (at your option) any later version.
-
-This library is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-Lesser General Public License for more details.
-
-You should have received a copy of the GNU Lesser General Public
-License along with this library; if not, write to the Free Software
-Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+Copyright (c) 2006 by the respective authors (see AUTHORS file).
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+ * The names of the contributors may not be used to endorse or
+ promote products derived from this software without specific
+ prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/TODO b/TODO
index cdfa3fa0..b2dbcb25 100644
--- a/TODO
+++ b/TODO
@@ -9,7 +9,7 @@ for 0.6
- pygmentize presets?
-- short cmdline options for common -O options
+- short cmdline options for common ``-O`` options
- html formatter: full document, external css file?
@@ -17,30 +17,30 @@ for 0.6
- more unit tests (pygmentize, all formatters)
-- help for -O and -a cmdline options
+- help for ``-O`` and ``-a`` cmdline options
- allow "overlay" token types (e.g. Diff + X)
- highlight specials: nth line, a word etc.
- dhtml: overlays toggleable by javascript
- lexers:
+ * bash
+ * haskell
* (Q)BASIC
+ * lisp
* apacheconf
* python TBs
- * haskell
* ls -alG
- * python help() ?
* HTML with special formatting?
+ * latex special formatting?
* ocaml
* nemerle
- * lisp
* windows batch files
* assembler
* objective c
- * bash
* mysql/postgresql/sqlite
* tcl
- * latex special formatting?
+ * python help() ?
- tell the PHP and DelphiLexer how to differ between Operators and
text.
diff --git a/docs/generate.py b/docs/generate.py
index 8759042b..91a280e3 100644
--- a/docs/generate.py
+++ b/docs/generate.py
@@ -7,7 +7,7 @@
Generates a bunch of html files containing the documentation.
:copyright: 2006 by Armin Ronacher, Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import os
diff --git a/pygments/__init__.py b/pygments/__init__.py
index bb2e1d45..c94e058c 100644
--- a/pygments/__init__.py
+++ b/pygments/__init__.py
@@ -20,12 +20,12 @@
is installable via *easy_install* with ``easy_install Pygments==dev``.
:copyright: 2006 by Georg Brandl, Armin Ronacher, Lukas Meuser and others.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
__version__ = '0.6'
__docformat__ = 'restructuredtext'
-__license__ = 'GNU Lesser General Public License (LGPL)'
+__license__ = 'BSD License'
__author__ = 'Georg Brandl <g.brandl@gmx.net>'
__url__ = 'http://pygments.pocoo.org/'
diff --git a/pygments/console.py b/pygments/console.py
index 6269c2f2..afc97736 100644
--- a/pygments/console.py
+++ b/pygments/console.py
@@ -6,7 +6,7 @@
Format colored console output.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
esc = "\x1b["
diff --git a/pygments/formatter.py b/pygments/formatter.py
index 47477f34..c750f0d8 100644
--- a/pygments/formatter.py
+++ b/pygments/formatter.py
@@ -6,7 +6,7 @@
Base formatter class.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.util import get_bool_opt
diff --git a/pygments/formatters/__init__.py b/pygments/formatters/__init__.py
index ecbc7b41..09f4e195 100644
--- a/pygments/formatters/__init__.py
+++ b/pygments/formatters/__init__.py
@@ -6,7 +6,7 @@
Pygments formatters.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import os.path
from pygments.formatters.html import HtmlFormatter
diff --git a/pygments/formatters/bbcode.py b/pygments/formatters/bbcode.py
index 813e0d4c..0e9338bd 100644
--- a/pygments/formatters/bbcode.py
+++ b/pygments/formatters/bbcode.py
@@ -6,7 +6,7 @@
BBcode formatter.
:copyright: 2006 by Lukas Meuser.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
diff --git a/pygments/formatters/html.py b/pygments/formatters/html.py
index 45e11194..175803bd 100644
--- a/pygments/formatters/html.py
+++ b/pygments/formatters/html.py
@@ -6,7 +6,7 @@
Formatter for HTML output.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import cStringIO
diff --git a/pygments/formatters/latex.py b/pygments/formatters/latex.py
index 27b0c5fe..305bb174 100644
--- a/pygments/formatters/latex.py
+++ b/pygments/formatters/latex.py
@@ -6,7 +6,7 @@
Formatter for LaTeX fancyvrb output.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import cStringIO
diff --git a/pygments/formatters/other.py b/pygments/formatters/other.py
index affbbfc2..11e2566c 100644
--- a/pygments/formatters/other.py
+++ b/pygments/formatters/other.py
@@ -6,7 +6,7 @@
Other formatters: NullFormatter, RawTokenFormatter.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.formatter import Formatter
diff --git a/pygments/formatters/terminal.py b/pygments/formatters/terminal.py
index 11f0b26a..fdfb6c2c 100644
--- a/pygments/formatters/terminal.py
+++ b/pygments/formatters/terminal.py
@@ -6,7 +6,7 @@
Formatter for terminal output with ANSI sequences.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.formatter import Formatter
diff --git a/pygments/lexer.py b/pygments/lexer.py
index 5b5d18ba..fa236d28 100644
--- a/pygments/lexer.py
+++ b/pygments/lexer.py
@@ -6,7 +6,7 @@
Base lexer classes.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/__init__.py b/pygments/lexers/__init__.py
index 751d49bc..0f2b7093 100644
--- a/pygments/lexers/__init__.py
+++ b/pygments/lexers/__init__.py
@@ -6,7 +6,7 @@
Pygments lexers.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import fnmatch
import types
diff --git a/pygments/lexers/_luabuiltins.py b/pygments/lexers/_luabuiltins.py
index b680d1c8..c7c1496b 100644
--- a/pygments/lexers/_luabuiltins.py
+++ b/pygments/lexers/_luabuiltins.py
@@ -10,7 +10,7 @@
Do not edit the MODULES dict by hand.
:copyright: 2006 by Lukas Meuser.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
MODULES = {'basic': ['_G',
diff --git a/pygments/lexers/_mapping.py b/pygments/lexers/_mapping.py
index 68b8be3c..ab56d8c0 100644
--- a/pygments/lexers/_mapping.py
+++ b/pygments/lexers/_mapping.py
@@ -10,7 +10,7 @@
Do not alter the LEXERS dictionary by hand.
:copyright: 2006 by Armin Ronacher, Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
LEXERS = {
diff --git a/pygments/lexers/_phpbuiltins.py b/pygments/lexers/_phpbuiltins.py
index 626bc99b..0a49dd09 100644
--- a/pygments/lexers/_phpbuiltins.py
+++ b/pygments/lexers/_phpbuiltins.py
@@ -13,7 +13,7 @@
a server ;-)
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
diff --git a/pygments/lexers/agile.py b/pygments/lexers/agile.py
index af3aef1d..5e074731 100644
--- a/pygments/lexers/agile.py
+++ b/pygments/lexers/agile.py
@@ -7,7 +7,7 @@
:copyright: 2006 by Georg Brandl, Armin Ronacher,
Lukas Meuser, Marek Kubica.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
@@ -906,7 +906,7 @@ class SchemeLexer(RegexLexer):
# find the remaining variables
(valid_name, Name.Variable),
- # the famous parantheses!
+ # the famous parentheses!
(r'(\(|\))', Punctuation),
],
}
diff --git a/pygments/lexers/compiled.py b/pygments/lexers/compiled.py
index 9fea6808..491c234c 100644
--- a/pygments/lexers/compiled.py
+++ b/pygments/lexers/compiled.py
@@ -6,7 +6,7 @@
Lexers for compiled languages: C/C++, Delphi, Java.
:copyright: 2006 by Georg Brandl, Armin Ronacher, Christoph Hack.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/dotnet.py b/pygments/lexers/dotnet.py
index a32298bf..c240d17a 100644
--- a/pygments/lexers/dotnet.py
+++ b/pygments/lexers/dotnet.py
@@ -6,7 +6,7 @@
.net languages
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/other.py b/pygments/lexers/other.py
index 01822fc5..4c3b524f 100644
--- a/pygments/lexers/other.py
+++ b/pygments/lexers/other.py
@@ -6,7 +6,7 @@
Lexers for other languages: SQL, BrainFuck.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/special.py b/pygments/lexers/special.py
index e0d26e8c..fb033647 100644
--- a/pygments/lexers/special.py
+++ b/pygments/lexers/special.py
@@ -6,7 +6,7 @@
Special lexers.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/templates.py b/pygments/lexers/templates.py
index 64dad6f0..495c04fe 100644
--- a/pygments/lexers/templates.py
+++ b/pygments/lexers/templates.py
@@ -6,7 +6,7 @@
Lexers for various template engines.
:copyright: 2006 by Armin Ronacher, Georg Brandl, Matt Good.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/text.py b/pygments/lexers/text.py
index b2c38ebb..c322badf 100644
--- a/pygments/lexers/text.py
+++ b/pygments/lexers/text.py
@@ -6,7 +6,7 @@
Lexers for non-source code file types: Diff, Makefiles, Ini configs etc.
:copyright: 2006 by Armin Ronacher, Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/lexers/web.py b/pygments/lexers/web.py
index 7e74ccb5..904c8c11 100644
--- a/pygments/lexers/web.py
+++ b/pygments/lexers/web.py
@@ -6,7 +6,7 @@
Lexers for web-related languages: JavaScript, CSS, HTML, XML, PHP.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/plugin.py b/pygments/plugin.py
index 672bb6ad..4422cbb5 100644
--- a/pygments/plugin.py
+++ b/pygments/plugin.py
@@ -28,7 +28,7 @@
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
try:
import pkg_resources
diff --git a/pygments/scanner.py b/pygments/scanner.py
index ba7d8a2e..34406cf6 100644
--- a/pygments/scanner.py
+++ b/pygments/scanner.py
@@ -13,7 +13,7 @@
this scanner.
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/pygments/style.py b/pygments/style.py
index caf6ca00..66d778af 100644
--- a/pygments/style.py
+++ b/pygments/style.py
@@ -6,7 +6,7 @@
Basic style object.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.token import Token, STANDARD_TYPES
diff --git a/pygments/styles/__init__.py b/pygments/styles/__init__.py
index a8a502eb..0dc97322 100644
--- a/pygments/styles/__init__.py
+++ b/pygments/styles/__init__.py
@@ -6,7 +6,7 @@
Contains built-in styles.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.plugin import find_plugin_styles
diff --git a/pygments/styles/autumn.py b/pygments/styles/autumn.py
index 69656433..0e9c64d2 100644
--- a/pygments/styles/autumn.py
+++ b/pygments/styles/autumn.py
@@ -6,7 +6,7 @@
A colorful style, inspired by the terminal highlighting style.
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/borland.py b/pygments/styles/borland.py
index ac47b2de..e6c14b19 100644
--- a/pygments/styles/borland.py
+++ b/pygments/styles/borland.py
@@ -6,7 +6,7 @@
Style similar to the style used in the borland ides.
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/colorful.py b/pygments/styles/colorful.py
index c718f53e..0e3bc5e6 100644
--- a/pygments/styles/colorful.py
+++ b/pygments/styles/colorful.py
@@ -6,7 +6,7 @@
A colorful style, inspired by CodeRay.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/default.py b/pygments/styles/default.py
index 9d6fd05c..277c323f 100644
--- a/pygments/styles/default.py
+++ b/pygments/styles/default.py
@@ -6,7 +6,7 @@
The default highlighting style for Pygments.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/friendly.py b/pygments/styles/friendly.py
index 0aee6a2c..af983909 100644
--- a/pygments/styles/friendly.py
+++ b/pygments/styles/friendly.py
@@ -6,7 +6,7 @@
A modern style based on the VIM pyte theme.
:copyright: 2006 by Georg Brandl, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/manni.py b/pygments/styles/manni.py
index 7805a57a..61e041fc 100644
--- a/pygments/styles/manni.py
+++ b/pygments/styles/manni.py
@@ -8,14 +8,8 @@
This is a port of the style used in the `php port`_ of pygments
by Manni. The style is called 'default' there.
- By now Mannis php highlighter isn't licensed under a open source
- license but because it uses code from the pygments library it must
- be LGPL compatible sooner or later. ;-)
-
- .. _php port:: http://svn.fnord.name/manni/fnord.bb/lib/Highlighter/
-
:copyright: 2006 by Armin Ronacher, Manni <manni@fnord.name>.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/murphy.py b/pygments/styles/murphy.py
index 258be9ee..425a1683 100644
--- a/pygments/styles/murphy.py
+++ b/pygments/styles/murphy.py
@@ -6,7 +6,7 @@
Murphy's style from CodeRay.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/native.py b/pygments/styles/native.py
index d30c27ae..057e66ce 100644
--- a/pygments/styles/native.py
+++ b/pygments/styles/native.py
@@ -6,7 +6,7 @@
pygments version of my "native" vim theme.
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/pastie.py b/pygments/styles/pastie.py
index 8763a2c1..a6b3a444 100644
--- a/pygments/styles/pastie.py
+++ b/pygments/styles/pastie.py
@@ -8,7 +8,7 @@
.. _pastie: http://pastie.caboo.se/
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/perldoc.py b/pygments/styles/perldoc.py
index f3f8985e..300d8d25 100644
--- a/pygments/styles/perldoc.py
+++ b/pygments/styles/perldoc.py
@@ -8,7 +8,7 @@
.. _perldoc: http://perldoc.perl.org/
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/styles/trac.py b/pygments/styles/trac.py
index 829b8501..158b1f82 100644
--- a/pygments/styles/trac.py
+++ b/pygments/styles/trac.py
@@ -6,7 +6,7 @@
Port of the default trac highlighter design.
:copyright: 2006 by Edgewall, Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
from pygments.style import Style
diff --git a/pygments/token.py b/pygments/token.py
index b49fd61a..f9ab7442 100644
--- a/pygments/token.py
+++ b/pygments/token.py
@@ -6,7 +6,7 @@
Basic token types and the standard tokens.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
class _TokenType(tuple):
diff --git a/pygments/util.py b/pygments/util.py
index 94b1bd21..8a1434b4 100644
--- a/pygments/util.py
+++ b/pygments/util.py
@@ -6,7 +6,7 @@
Utility functions.
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
diff --git a/scripts/check_sources.py b/scripts/check_sources.py
index d8f4f82b..e769abf8 100755
--- a/scripts/check_sources.py
+++ b/scripts/check_sources.py
@@ -126,7 +126,7 @@ def check_fileheader(fn, lines):
# check for copyright and license fields
license = llist[-2:-1]
- if license != [" :license: GNU LGPL, see LICENSE for more details.\n"]:
+ if license != [" :license: BSD, see LICENSE for more details.\n"]:
yield 0, "no correct license info"
ci = -3
diff --git a/scripts/find_abandoned_lexers.py b/scripts/find_abandoned_lexers.py
index 1f837d23..ccd57429 100644
--- a/scripts/find_abandoned_lexers.py
+++ b/scripts/find_abandoned_lexers.py
@@ -9,7 +9,7 @@
to check the mimetypes, filename patterns and aliases too.
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import re
import sys
diff --git a/scripts/vim2pygments.py b/scripts/vim2pygments.py
index 80ca2386..42cd151d 100644
--- a/scripts/vim2pygments.py
+++ b/scripts/vim2pygments.py
@@ -8,7 +8,7 @@
style classes meant for putting into modules.
:copyright 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import sys
diff --git a/setup.py b/setup.py
index 05617a89..b970b3a5 100644
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ setup(
zip_safe = False,
include_package_data = True,
classifiers = [
- 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'License :: OSI Approved :: BSD License',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: System Administrators',
diff --git a/tests/test_basic_api.py b/tests/test_basic_api.py
index 0301f290..b256310c 100644
--- a/tests/test_basic_api.py
+++ b/tests/test_basic_api.py
@@ -4,7 +4,7 @@
~~~~~~~~~~~~~~~~~~~~~~~~
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import unittest
diff --git a/tests/test_clexer.py b/tests/test_clexer.py
index 4c0ca4bf..10e88afd 100644
--- a/tests/test_clexer.py
+++ b/tests/test_clexer.py
@@ -4,7 +4,7 @@
~~~~~~~~~~~~~~~~~
:copyright: 2006 by Armin Ronacher.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import unittest
diff --git a/tests/test_cmdline.py b/tests/test_cmdline.py
index 1126e695..3f359cf1 100644
--- a/tests/test_cmdline.py
+++ b/tests/test_cmdline.py
@@ -4,7 +4,7 @@
~~~~~~~~~~~~~~~~~
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
# Test the command line interface
diff --git a/tests/test_examplefiles.py b/tests/test_examplefiles.py
index 2c779618..d5279071 100644
--- a/tests/test_examplefiles.py
+++ b/tests/test_examplefiles.py
@@ -4,7 +4,7 @@
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:copyright: 2006 by Georg Brandl.
- :license: GNU LGPL, see LICENSE for more details.
+ :license: BSD, see LICENSE for more details.
"""
import unittest