summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/check_sources.py3
-rw-r--r--scripts/release-checklist24
2 files changed, 26 insertions, 1 deletions
diff --git a/scripts/check_sources.py b/scripts/check_sources.py
index db09de42..c0524b6c 100755
--- a/scripts/check_sources.py
+++ b/scripts/check_sources.py
@@ -185,7 +185,8 @@ def main(argv):
print("Checking %s..." % fn)
try:
- lines = open(fn, 'rb').read().decode('utf-8').splitlines()
+ with open(fn, 'rb') as f:
+ lines = f.read().decode('utf-8').splitlines()
except (IOError, OSError) as err:
print("%s: cannot open: %s" % (fn, err))
num += 1
diff --git a/scripts/release-checklist b/scripts/release-checklist
new file mode 100644
index 00000000..efc1e1e8
--- /dev/null
+++ b/scripts/release-checklist
@@ -0,0 +1,24 @@
+Release checklist
+=================
+
+* Check ``hg status``
+* ``make check``
+* LATER when configured properly: ``make pylint``
+* ``tox``
+* Update version info in ``setup.py/__init__.py``
+* Check setup.py metadata: long description, trove classifiers
+* Update release date/code name in ``CHANGES``
+* ``hg commit``
+* ``make clean``
+* ``python2 setup.py release bdist_wheel``
+* ``python3 setup.py release bdist_wheel sdist``
+* ``twine upload dist/Pygments-$NEWVER*``
+* Check PyPI release page for obvious errors
+* ``hg tag``
+* Merge default into stable if this was a ``x.y.0``
+* Update homepage (release info), regenerate docs (+printable!)
+* Add new version/milestone to tracker categories
+* Write announcement and send to mailing list/python-announce
+* Update version info, add new ``CHANGES`` entry for next version
+* ``hg commit``
+* ``hg push``