summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/release-checklist32
1 files changed, 16 insertions, 16 deletions
diff --git a/scripts/release-checklist b/scripts/release-checklist
index f18e6376..efc1e1e8 100644
--- a/scripts/release-checklist
+++ b/scripts/release-checklist
@@ -1,24 +1,24 @@
Release checklist
=================
-* Check hg status
-* Make check
-* Make pylint
-* Make test from clean checkout with all supported Python versions
-* Update ez_setup.py
-* Update version info in setup.py/__init__.py
+* Check ``hg status``
+* ``make check``
+* LATER when configured properly: ``make pylint``
+* ``tox``
+* Update version info in ``setup.py/__init__.py``
* Check setup.py metadata: long description, trove classifiers
-* Update release date/code name in CHANGES
-* hg commit
-* make clean
-* For every supported version:
- pythonX.Y setup.py release bdist_egg sdist upload
+* Update release date/code name in ``CHANGES``
+* ``hg commit``
+* ``make clean``
+* ``python2 setup.py release bdist_wheel``
+* ``python3 setup.py release bdist_wheel sdist``
+* ``twine upload dist/Pygments-$NEWVER*``
* Check PyPI release page for obvious errors
-* hg tag
-* Make a maintenance branch if applicable
+* ``hg tag``
+* Merge default into stable if this was a ``x.y.0``
* Update homepage (release info), regenerate docs (+printable!)
* Add new version/milestone to tracker categories
* Write announcement and send to mailing list/python-announce
-* Update version info, add new CHANGES entry for next version
-* hg commit
-* hg push
+* Update version info, add new ``CHANGES`` entry for next version
+* ``hg commit``
+* ``hg push``