summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py55
1 files changed, 24 insertions, 31 deletions
diff --git a/setup.py b/setup.py
index 17bbf814..951404e5 100755
--- a/setup.py
+++ b/setup.py
@@ -1,29 +1,22 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-"""
- Pygments
+"""Pygments
~~~~~~~~
Pygments is a syntax highlighting package written in Python.
- It is a generic syntax highlighter for general use in all kinds of software
- such as forum systems, wikis or other applications that need to prettify
- source code. Highlights are:
+ It is a generic syntax highlighter suitable for use in code hosting, forums,
+ wikis or other applications that need to prettify source code. Highlights
+ are:
- * a wide range of common languages and markup formats is supported
+ * a wide range of over 300 languages and other text formats is supported
* special attention is paid to details, increasing quality by a fair amount
* support for new languages and formats are added easily
* a number of output formats, presently HTML, LaTeX, RTF, SVG, all image \
formats that PIL supports and ANSI sequences
* it is usable as a command-line tool and as a library
- * ... and it highlights even Brainfuck!
-
- The `Pygments tip`_ is installable with ``easy_install Pygments==dev``.
-
- .. _Pygments tip:
- http://bitbucket.org/birkenfeld/pygments-main/get/default.zip#egg=Pygments-dev
- :copyright: Copyright 2006-2013 by the Pygments team, see AUTHORS.
+ :copyright: Copyright 2006-2015 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
"""
@@ -31,21 +24,22 @@ try:
from setuptools import setup, find_packages
have_setuptools = True
except ImportError:
- from distutils.core import setup
- def find_packages():
- return [
- 'pygments',
- 'pygments.lexers',
- 'pygments.formatters',
- 'pygments.styles',
- 'pygments.filters',
- ]
- have_setuptools = False
-
-try:
- from distutils.command.build_py import build_py_2to3 as build_py
-except ImportError:
- from distutils.command.build_py import build_py
+ try:
+ import ez_setup
+ ez_setup.use_setuptools()
+ from setuptools import setup, find_packages
+ have_setuptools = True
+ except ImportError:
+ from distutils.core import setup
+ def find_packages(*args, **kwargs):
+ return [
+ 'pygments',
+ 'pygments.lexers',
+ 'pygments.formatters',
+ 'pygments.styles',
+ 'pygments.filters',
+ ]
+ have_setuptools = False
if have_setuptools:
add_keywords = dict(
@@ -60,7 +54,7 @@ else:
setup(
name = 'Pygments',
- version = '1.6',
+ version = '2.1a0',
url = 'http://pygments.org/',
license = 'BSD License',
author = 'Georg Brandl',
@@ -68,7 +62,7 @@ setup(
description = 'Pygments is a syntax highlighting package written in Python.',
long_description = __doc__,
keywords = 'syntax highlighting',
- packages = find_packages(),
+ packages = find_packages(exclude=['ez_setup']),
platforms = 'any',
zip_safe = False,
include_package_data = True,
@@ -85,6 +79,5 @@ setup(
'Topic :: Text Processing :: Filters',
'Topic :: Utilities',
],
- cmdclass = {'build_py': build_py},
**add_keywords
)