summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Adams <mark@markadams.me>2015-10-09 14:00:12 -0500
committerMark Adams <mark@markadams.me>2015-10-09 14:00:12 -0500
commit89a82790fabf0f5e555bd1226d8507820e41b092 (patch)
treeb3c1e100b57007f2bcbc95686e19e628c472153c
parentc5ee34e86bc42bef60ef6e701df569c2c86a5d5d (diff)
parentacc30b90666f2edb891a674bbb1727114776421a (diff)
downloadpyjwt-89a82790fabf0f5e555bd1226d8507820e41b092.tar.gz
Merge pull request #182 from mark-adams/fix-pytest
Fixes an issue where the newer versions of Pytest can't detect deprecation warnings
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini3
2 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 30209e4..452e4e5 100755
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ if sys.argv[-1] == 'publish':
sys.exit()
tests_require = [
- 'pytest',
+ 'pytest==2.7.3',
'pytest-cov',
'pytest-runner',
]
diff --git a/tox.ini b/tox.ini
index 5c59e8f..df91787 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,9 +6,6 @@ commands =
python setup.py pytest
deps =
crypto: cryptography
- pytest
- pytest-cov
- pytest-runner
contrib_crypto: pycrypto
contrib_crypto: ecdsa