summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Padilla <jpadilla@webapplicate.com>2019-11-23 13:24:09 -0500
committerJosé Padilla <jpadilla@webapplicate.com>2019-11-23 13:24:09 -0500
commit806fe6aa4000997a385d009f3a45e3b4de4d0d5f (patch)
treeacc77b7ac9acceafc641618fc27baf8c2c287801
parente875db1357f38450a7c2693aea728c931ddadfe3 (diff)
downloadpyjwt-806fe6aa4000997a385d009f3a45e3b4de4d0d5f.tar.gz
Update CHANGELOG.md
-rw-r--r--CHANGELOG.md17
1 files changed, 17 insertions, 0 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index fa42d8f..1a2f5ef 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -8,10 +8,27 @@ This project adheres to [Semantic Versioning](https://semver.org/).
-------------------------------------------------------------------------
### Changed
+- Pass python_requires argument to setuptools #440
+- Rename [wheel] section to [bdist_wheel] as the former is legacy #441
+- Remove setup.py test command in favor of pytest and tox #442
+- DX Tweaks #450
+- Remove Python 2.7 compatibility #457
+
### Fixed
+- Decode return type is dict[str, Any] #393
+- Fix linter error in test_cli #414
+- Correct type for json_encoder argument #438
+- Run mypy with tox #421
+- Prefer https:// links where available #439
+- Fix mypy errors #449
+- Fix simple typo: encododed -> encoded #462
+
### Added
+- Document (and prefer) pyjwt[crypto] req format #426
+- Set headers when encoding via command line #406
+
[v1.7.1][1.7.1]
-------------------------------------------------------------------------