summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Padilla <jpadilla@webapplicate.com>2015-04-15 16:51:42 -0400
committerJosé Padilla <jpadilla@webapplicate.com>2015-04-15 16:51:42 -0400
commit28fc115b37f042475c920527d7cb6b9e0599ccb5 (patch)
treeaaa7eb8876f7ab514a45f440bc524b4e399572f6
parent9036e7346f3daf4360015c41a8bdf25160767881 (diff)
downloadpyjwt-28fc115b37f042475c920527d7cb6b9e0599ccb5.tar.gz
Update CHANGELOG.md for v1.1.0
-rw-r--r--CHANGELOG.md55
1 files changed, 40 insertions, 15 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d687f31..d0ac3ef 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -7,35 +7,60 @@ This project adheres to [Semantic Versioning](http://semver.org/).
[Unreleased][unreleased]
-------------------------------------------------------------------------
### Changed
-- Added flexible and complete verification options during decode #131
-- Deprecated usage of the .decode(..., verify=False) parameter
-- Added support for PS256, PS384, and PS512 algorithms. #132
-- Added this CHANGELOG.md file
+- Placeholder
### Fixed
- Placeholder
+[v1.1.0][1.1.0]
+-------------------------------------------------------------------------
+### Added
+- Added support for PS256, PS384, and PS512 algorithms. [#132][132]
+- Added flexible and complete verification options during decode. [#131][131]
+- Added this CHANGELOG.md file.
+
+
+### Deprecated
+- Deprecated usage of the .decode(..., verify=False) parameter.
+
+
+### Fixed
+- Fixed command line encoding. [#128][128]
+
[v1.0.1][1.0.1]
-------------------------------------------------------------------------
### Fixed
-- Include jwt/contrib' andjwt/contrib/algorithms` in setup.py so that they will
- actually be included when installing. Ref 882524d
-- Fix bin/jwt after removing jwt.header() Ref bd57b02
+- Include jwt/contrib' and jwt/contrib/algorithms` in setup.py so that they will
+ actually be included when installing. [882524d][882524d]
+- Fix bin/jwt after removing jwt.header(). [bd57b02][bd57b02]
[v1.0.0][1.0.0]
-------------------------------------------------------------------------
### Changed
-- Moved `jwt.api.header` out of the public API #85
-- Added README details how to extract public / private keys from an x509 certificate. #100
-- Refactor api.py functions into an object (`PyJWT`). #101
-- Added support for PyCrypto and ecdsa when cryptography isn't available. #103
+- Moved `jwt.api.header` out of the public API. [#85][85]
+- Added README details how to extract public / private keys from an x509 certificate. [#100][100]
+- Refactor api.py functions into an object (`PyJWT`). [#101][101]
+- Added support for PyCrypto and ecdsa when cryptography isn't available. [#101][103]
### Fixed
-- Fixed a security vulnerability where `alg=None` header could bypass signature verification #109
-- Fixed a security vulnerability by adding support for a whitelist of allowed `alg` values `jwt.decode(algorithms=[])` #110
+- Fixed a security vulnerability where `alg=None` header could bypass signature verification. [#109][109]
+- Fixed a security vulnerability by adding support for a whitelist of allowed `alg` values `jwt.decode(algorithms=[])`. [#110][110]
-[unreleased]: https://github.com/jpadilla/pyjwt/compare/1.0.1...HEAD
+[unreleased]: https://github.com/jpadilla/pyjwt/compare/1.1.0...HEAD
[1.0.1]: https://github.com/jpadilla/pyjwt/compare/1.0.0...1.0.1
-[1.0.0]: https://github.com/jpadilla/pyjwt/compare/0.4.3...1.0.0
+[1.0.1]: https://github.com/jpadilla/pyjwt/compare/1.0.0...1.0.1
+[1.1.0]: https://github.com/jpadilla/pyjwt/compare/1.0.1...1.1.0
+
+[109]: https://github.com/jpadilla/pyjwt/pull/109
+[110]: https://github.com/jpadilla/pyjwt/pull/110
+[100]: https://github.com/jpadilla/pyjwt/pull/100
+[101]: https://github.com/jpadilla/pyjwt/pull/101
+[103]: https://github.com/jpadilla/pyjwt/pull/103
+[85]: https://github.com/jpadilla/pyjwt/pull/85
+[882524d]: https://github.com/jpadilla/pyjwt/commit/882524d
+[bd57b02]: https://github.com/jpadilla/pyjwt/commit/bd57b02
+[131]: https://github.com/jpadilla/pyjwt/pull/131
+[132]: https://github.com/jpadilla/pyjwt/pull/132
+[128]: https://github.com/jpadilla/pyjwt/pull/128