summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Padilla <jpadilla@webapplicate.com>2018-12-06 07:32:27 -0500
committerJosé Padilla <jpadilla@webapplicate.com>2018-12-06 07:32:27 -0500
commitb65e1ac6dc4d11801f3642eaab34ae6a54162c18 (patch)
treec6688abf6d246f9729278c8ce76ea106c3604634
parent3f735fdf68cc865a6241aae1fcf92a410c73fbdb (diff)
downloadpyjwt-b65e1ac6dc4d11801f3642eaab34ae6a54162c18.tar.gz
Fix pytest and pinned test dependencies1.7.1
-rw-r--r--CHANGELOG.md9
-rw-r--r--jwt/__init__.py2
-rwxr-xr-xsetup.py6
-rw-r--r--tests/test_api_jws.py2
-rw-r--r--tests/test_api_jwt.py2
-rw-r--r--tests/test_utils.py2
6 files changed, 16 insertions, 7 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4681723..86c3d2d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -12,6 +12,14 @@ This project adheres to [Semantic Versioning](http://semver.org/).
### Added
+[v1.7.1][1.7.1]
+-------------------------------------------------------------------------
+
+### Fixed
+
+- Update test dependencies with pinned ranges
+- Fix pytest deprecation warnings
+
[v1.7.0][1.7.0]
-------------------------------------------------------------------------
@@ -228,6 +236,7 @@ rarely used. Users affected by this should upgrade to 3.3+.
[1.6.3]: https://github.com/jpadilla/pyjwt/compare/1.6.1...1.6.3
[1.6.4]: https://github.com/jpadilla/pyjwt/compare/1.6.3...1.6.4
[1.7.0]: https://github.com/jpadilla/pyjwt/compare/1.6.4...1.7.0
+[1.7.1]: https://github.com/jpadilla/pyjwt/compare/1.7.0...1.7.1
[109]: https://github.com/jpadilla/pyjwt/pull/109
[110]: https://github.com/jpadilla/pyjwt/pull/110
diff --git a/jwt/__init__.py b/jwt/__init__.py
index 2523680..946983f 100644
--- a/jwt/__init__.py
+++ b/jwt/__init__.py
@@ -10,7 +10,7 @@ http://self-issued.info/docs/draft-jones-json-web-token-01.html
__title__ = 'pyjwt'
-__version__ = '1.7.0'
+__version__ = '1.7.1'
__author__ = 'José Padilla'
__license__ = 'MIT'
__copyright__ = 'Copyright 2015-2018 José Padilla'
diff --git a/setup.py b/setup.py
index 7302e31..f175c95 100755
--- a/setup.py
+++ b/setup.py
@@ -33,9 +33,9 @@ if sys.argv[-1] == 'publish':
sys.exit()
tests_require = [
- 'pytest==3.7.1',
- 'pytest-cov==2.5.1',
- 'pytest-runner==4.2',
+ 'pytest>=4.0.1,<5.0.0',
+ 'pytest-cov>=2.6.0,<3.0.0',
+ 'pytest-runner>=4.2,<5.0.0',
]
needs_pytest = set(('pytest', 'test', 'ptr')).intersection(sys.argv)
diff --git a/tests/test_api_jws.py b/tests/test_api_jws.py
index 4bf8d39..4f70b56 100644
--- a/tests/test_api_jws.py
+++ b/tests/test_api_jws.py
@@ -294,7 +294,7 @@ class TestJWS:
jws.decode, example_jws, key=example_secret,
options={'verify_signature': False},
)
- except AssertionError:
+ except pytest.fail.Exception:
pass
else:
assert False, "Unexpected DeprecationWarning raised."
diff --git a/tests/test_api_jwt.py b/tests/test_api_jwt.py
index 8f550cb..8d07f3f 100644
--- a/tests/test_api_jwt.py
+++ b/tests/test_api_jwt.py
@@ -516,7 +516,7 @@ class TestJWT:
pytest.deprecated_call(
jwt.decode, jwt_message, secret, verify=False,
)
- except AssertionError:
+ except pytest.fail.Exception:
pass
else:
assert False, "Unexpected DeprecationWarning raised."
diff --git a/tests/test_utils.py b/tests/test_utils.py
index 7549faa..1408af2 100644
--- a/tests/test_utils.py
+++ b/tests/test_utils.py
@@ -11,7 +11,7 @@ import pytest
(255, b'_w'),
(65537, b'AQAB'),
(123456789, b'B1vNFQ'),
- pytest.mark.xfail((-1, ''), raises=ValueError)
+ pytest.param(-1, '', marks=pytest.mark.xfail(raises=ValueError))
])
def test_to_base64url_uint(inputval, expected):
actual = to_base64url_uint(inputval)