summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Padilla <jpadilla@webapplicate.com>2016-11-12 16:50:19 -0500
committerGitHub <noreply@github.com>2016-11-12 16:50:19 -0500
commit5caa1af9d57c3621596a12aeaa4693bda5f15596 (patch)
treebad5f11825b78a5ce8be135f3d2e555fef110e6f
parentb144666d063c65827123403609273d35f551ee63 (diff)
parentc5ea68827f5dc5564bde6c087c938189cbbf1f8a (diff)
downloadpyjwt-5caa1af9d57c3621596a12aeaa4693bda5f15596.tar.gz
Merge pull request #221 from adamchainz/readme
Convert README from Markdown to reStructuredText
-rw-r--r--MANIFEST.in2
-rw-r--r--README.md53
-rw-r--r--README.rst56
-rwxr-xr-xsetup.py2
4 files changed, 58 insertions, 55 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 38dbbef..144cf63 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,4 @@
-include README.md
+include README.rst
include CHANGELOG.md
include LICENSE
include AUTHORS
diff --git a/README.md b/README.md
deleted file mode 100644
index 0acc604..0000000
--- a/README.md
+++ /dev/null
@@ -1,53 +0,0 @@
-# PyJWT
-
-[![travis-status-image]][travis]
-[![appveyor-status-image]][appveyor]
-[![pypi-version-image]][pypi]
-[![coveralls-status-image]][coveralls]
-[![docs-status-image]][docs]
-
-A Python implementation of [RFC 7519][jwt-spec].
-Original implementation was written by [@progrium][progrium].
-
-
-## Installing
-
-```
-$ pip install PyJWT
-```
-
-## Usage
-
-```python
->>> import jwt
->>> encoded = jwt.encode({'some': 'payload'}, 'secret', algorithm='HS256')
-'eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzb21lIjoicGF5bG9hZCJ9.4twFt5NiznN84AWoo1d7KO1T_yoc0Z6XOpOVswacPZg'
-
->>> jwt.decode(encoded, 'secret', algorithms=['HS256'])
-{'some': 'payload'}
-```
-
-## Documentation
-
-View the full docs online at https://pyjwt.readthedocs.io/en/latest/
-
-## Tests
-
-You can run tests from the project root after cloning with:
-
-```
-$ python setup.py test
-```
-
-[travis-status-image]: https://secure.travis-ci.org/jpadilla/pyjwt.svg?branch=master
-[travis]: http://travis-ci.org/jpadilla/pyjwt?branch=master
-[appveyor-status-image]: https://ci.appveyor.com/api/projects/status/h8nt70aqtwhht39t?svg=true
-[appveyor]: https://ci.appveyor.com/project/jpadilla/pyjwt
-[pypi-version-image]: https://img.shields.io/pypi/v/pyjwt.svg
-[pypi]: https://pypi.python.org/pypi/pyjwt
-[coveralls-status-image]: https://coveralls.io/repos/jpadilla/pyjwt/badge.svg?branch=master
-[coveralls]: https://coveralls.io/r/jpadilla/pyjwt?branch=master
-[docs-status-image]: https://readthedocs.org/projects/pyjwt/badge/?version=latest
-[docs]: https://pyjwt.readthedocs.io
-[jwt-spec]: https://tools.ietf.org/html/rfc7519
-[progrium]: https://github.com/progrium
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..5d2a8ee
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,56 @@
+PyJWT
+=====
+
+.. image:: https://secure.travis-ci.org/jpadilla/pyjwt.svg?branch=master
+ :target: http://travis-ci.org/jpadilla/pyjwt?branch=master
+
+.. image:: https://ci.appveyor.com/api/projects/status/h8nt70aqtwhht39t?svg=true
+ :target: https://ci.appveyor.com/project/jpadilla/pyjwt
+
+.. image:: https://img.shields.io/pypi/v/pyjwt.svg
+ :target: https://pypi.python.org/pypi/pyjwt
+
+.. image:: https://coveralls.io/repos/jpadilla/pyjwt/badge.svg?branch=master
+ :target: https://coveralls.io/r/jpadilla/pyjwt?branch=master
+
+.. image:: https://readthedocs.org/projects/pyjwt/badge/?version=latest
+ :target: https://pyjwt.readthedocs.io
+
+A Python implementation of `RFC
+7519 <https://tools.ietf.org/html/rfc7519>`_. Original implementation
+was written by `@progrium <https://github.com/progrium>`_.
+
+Installing
+----------
+
+Install with **pip**:
+
+.. code-block:: sh
+
+ $ pip install PyJWT
+
+Usage
+-----
+
+.. code:: python
+
+ >>> import jwt
+ >>> encoded = jwt.encode({'some': 'payload'}, 'secret', algorithm='HS256')
+ 'eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzb21lIjoicGF5bG9hZCJ9.4twFt5NiznN84AWoo1d7KO1T_yoc0Z6XOpOVswacPZg'
+
+ >>> jwt.decode(encoded, 'secret', algorithms=['HS256'])
+ {'some': 'payload'}
+
+Documentation
+-------------
+
+View the full docs online at https://pyjwt.readthedocs.io/en/latest/
+
+Tests
+-----
+
+You can run tests from the project root after cloning with:
+
+.. code-block:: sh
+
+ $ python setup.py test
diff --git a/setup.py b/setup.py
index 3a98f53..274f249 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ def get_version(package):
version = get_version('jwt')
-with open(os.path.join(os.path.dirname(__file__), 'README.md')) as readme:
+with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as readme:
long_description = readme.read()
if sys.argv[-1] == 'publish':