summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Adams <mark@markadams.me>2015-01-24 17:27:34 -0600
committerMark Adams <mark@markadams.me>2015-01-24 17:30:13 -0600
commit12c8ca1cfdcb2acf1a22b000b8b9a8351b5e0de4 (patch)
treea525880daf4f703adc8c1fa73724a6ca1aa6bbce
parent971546674fdaef6ef8f63e371bb9e502209699b6 (diff)
downloadpyjwt-12c8ca1cfdcb2acf1a22b000b8b9a8351b5e0de4.tar.gz
Made a few changes to improve testing
- Fix: tox.ini now installs its own coverage.py locally so that it actually runs in the virtualenv's context. - Added py34 to Travis-CI configuration like the tox configuration - Changed TOX_ENV to TOXENV in Travis config to simplify the tox cmd - Moved `coverage erase` to tox.ini - Added `coverage report -m` to tox.ini so that a coverage report will output to the CLI when running `tox` locally.
-rw-r--r--.travis.yml12
-rw-r--r--tox.ini6
2 files changed, 11 insertions, 7 deletions
diff --git a/.travis.yml b/.travis.yml
index 0977bce..5ab5d82 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,14 +2,14 @@ language: python
python: 2.7
sudo: false
env:
- - TOX_ENV=py26
- - TOX_ENV=py27
- - TOX_ENV=py32
- - TOX_ENV=py33
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py34
install:
- pip install tox coveralls
script:
- - coverage erase
- - tox -e $TOX_ENV
+ - tox
after_success:
- coveralls
diff --git a/tox.ini b/tox.ini
index 18662fe..1bfff48 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,7 +2,11 @@
envlist = py26, py27, py32, py33, py34
[testenv]
-commands = coverage run setup.py test
+commands =
+ coverage erase
+ coverage run setup.py test
+ coverage report -m
deps =
cryptography
unittest2
+ coverage