summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-09-28 13:32:04 -0700
committerJosé Padilla <jpadilla@webapplicate.com>2019-09-28 16:32:04 -0400
commit12eaf0057e431e77ddba34715d138986e7039030 (patch)
tree589ac4c12754195691b2c373160720becf824413
parent6834f9e3b260814081bbe472498c45267f6711bc (diff)
downloadpyjwt-12eaf0057e431e77ddba34715d138986e7039030.tar.gz
Pass python_requires argument to setuptools (#440)
Helps pip decide what version of the library to install. This is especially useful when removing support for EOL Python versions. https://packaging.python.org/guides/distributing-packages-using-setuptools/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9cf85e1..9ece6dc 100755
--- a/setup.py
+++ b/setup.py
@@ -67,6 +67,7 @@ setup(
'Programming Language :: Python :: 3.7',
'Topic :: Utilities',
],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
test_suite='tests',
setup_requires=pytest_runner,
tests_require=tests_require,