summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2020-06-07 22:09:31 -0700
committerGitHub <noreply@github.com>2020-06-08 11:09:31 +0600
commit7b2b4ff50461186a60132f0ebf63b55a78aa831f (patch)
treeb76fa793a6fc652edab56cf53b17cab42229428a
parentd1b0ff33d869c9e36ae09f252eee18899bd656cf (diff)
downloadpyjwt-7b2b4ff50461186a60132f0ebf63b55a78aa831f.tar.gz
Add Python-3-only trove classifier and remove "universal" from wheel (#492)
Documents the project as Python 3 only to potential and current library users. As the project no longer supports Python 2, the wheel is not "universal". From https://wheel.readthedocs.io/en/stable/user_guide.html?highlight=universal#building-wheels: > If your project … is expected to work on both Python 2 and 3, you will > want to tell wheel to produce universal wheels …
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4d45f9f..71353cd 100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,7 @@ setup(
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
@@ -70,5 +71,4 @@ setup(
python_requires=">=3.5",
extras_require=EXTRAS_REQUIRE,
entry_points={"console_scripts": ["pyjwt = jwt.__main__:main"]},
- options={"bdist_wheel": {"universal": "1"}},
)