summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-05-04 21:42:44 -0400
committerJosé Padilla <jpadilla@webapplicate.com>2019-05-04 21:42:44 -0400
commit2f31a58405130bb897225ddbb17f64087fb81e70 (patch)
tree9c0ee765e8321f26aedfdddc82057a2fe9976503
parent5a9c34f2ebd55fce52a19e57974df86ac5a5f8c2 (diff)
downloadpyjwt-2f31a58405130bb897225ddbb17f64087fb81e70.tar.gz
Invoke pytest directly. Avoids use of easy_install and interaction between flake8 and tests. Fixes #416. (#417)
-rw-r--r--tox.ini8
1 files changed, 3 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index 3c93faa..89a0d47 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,16 +3,14 @@ envlist = py{27,34,35,36,37}-crypto, py{27,35,36,37}-contrib_crypto, py{27,35,36
[testenv]
commands =
- python setup.py pytest
+ pytest
deps =
crypto: cryptography
contrib_crypto: pycrypto
contrib_crypto: ecdsa
+extras = test
[testenv:flake8]
commands =
flake8
-deps =
- flake8
- flake8-import-order
- pep8-naming
+extras = flake8