summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <benjamin.drung@profitbricks.com>2018-09-25 18:35:53 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2018-09-28 14:34:49 +0200
commit3c2fb0ef2f640675079a1f9c56d2bc81f7b809dd (patch)
tree29fc624cd43ae31f1dc9461416ff9a35ce8defbd
parenta5b97de22b208bd8d4fc3b19ef487ffba330264d (diff)
downloadpylint-git-3c2fb0ef2f640675079a1f9c56d2bc81f7b809dd.tar.gz
[doc] Support specifying the Python interpreter
On Debian, the binary `python` will always point to Python 2. When building the documentation, there is no way to change the Python interpreter to Python 3 on Debian. Therefore allow specifying PYTHON to override the Python interpreter.
-rw-r--r--doc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 95df02f52..8d9480c87 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -7,6 +7,7 @@ SPHINXBUILD = sphinx-build
PIP = pip
PAPER =
BUILDDIR = _build
+PYTHON = /usr/bin/env python
PYTHONPATH =
# Internal variables.
@@ -143,13 +144,13 @@ extensions.rst: ../pylint/utils.py
extensions.rst: $(shell find ../pylint/extensions -type f -regex '.*\.py')
extensions.rst: $(shell find ../pylint/extensions -type f -regex '.*\.rst')
rm -f extensions.rst
- PYTHONPATH=$(PYTHONPATH) ./exts/pylint_extensions.py
+ PYTHONPATH=$(PYTHONPATH) $(PYTHON) ./exts/pylint_extensions.py
features.rst: exts/pylint_features.py
features.rst: ../pylint/utils.py
features.rst: $(shell find ../pylint/checkers -type f -regex '.*\.py')
rm -f features.rst
- PYTHONPATH=$(PYTHONPATH) ./exts/pylint_features.py
+ PYTHONPATH=$(PYTHONPATH) $(PYTHON) ./exts/pylint_features.py
gen-examples:
chmod u+w ../examples/pylintrc