summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVille Skyttä <ville.skytta@iki.fi>2020-05-05 17:41:18 +0300
committerClaudiu Popa <pcmanticore@gmail.com>2020-05-06 19:50:43 +0200
commit4756b3c611ef710c99b51d2fe5f04d72b28e75d6 (patch)
treedfb9fe5da2f0e5ecf82ec3e9311edf9ae82c56a7
parent43449dea6ad4f77af3290b12ba5cbae83bfb98d8 (diff)
downloadpylint-git-4756b3c611ef710c99b51d2fe5f04d72b28e75d6.tar.gz
Add What's New project URL
Background info at https://github.com/pypa/warehouse/pull/7882
-rw-r--r--pylint/__pkginfo__.py1
-rw-r--r--setup.py2
2 files changed, 3 insertions, 0 deletions
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index 8a70ddd26..9bbd0ce31 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -51,6 +51,7 @@ license = "GPL"
description = "python code static checker"
web = "https://github.com/PyCQA/pylint"
mailinglist = "mailto:code-quality@python.org"
+project_urls = {"What's New": "https://pylint.pycqa.org/en/latest/whatsnew/"}
author = "Python Code Quality Authority"
author_email = "code-quality@python.org"
diff --git a/setup.py b/setup.py
index 92d059ffc..7ceb14800 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ ext_modules = __pkginfo__.get("ext_modules", None)
install_requires = __pkginfo__.get("install_requires", None)
dependency_links = __pkginfo__.get("dependency_links", [])
extras_require = __pkginfo__.get("extras_require", {})
+project_urls = __pkginfo__.get("project_urls", {})
readme_path = join(base_dir, "README.rst")
if exists(readme_path):
@@ -153,6 +154,7 @@ def install(**kwargs):
python_requires=">=3.5.*",
setup_requires=pytest_runner,
tests_require=["pytest"],
+ project_urls=project_urls,
**kwargs
)