summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-11-12 09:05:45 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-11-12 18:00:31 +0100
commit774c37303746016ae1e73ec84c1deb4e344171a7 (patch)
tree260938718eba0b7ea232d4e78b0bdbaf9b4695e0
parent2a98bb089860cb0f1151543ff9a9e342fb34ea9d (diff)
downloadpylint-git-774c37303746016ae1e73ec84c1deb4e344171a7.tar.gz
Add a docstring to get_expected_or_default following review
See https://github.com/PyCQA/pylint/pull/5287\#discussion_r746971021
-rw-r--r--pylint/testutils/configuration_test.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/pylint/testutils/configuration_test.py b/pylint/testutils/configuration_test.py
index 2ff8ae0f2..9c3c6349d 100644
--- a/pylint/testutils/configuration_test.py
+++ b/pylint/testutils/configuration_test.py
@@ -22,6 +22,8 @@ PylintConfiguration = Dict[str, ConfigurationValue]
def get_expected_or_default(
pyproject_toml_path: str, suffix: str, default: ConfigurationValue
) -> str:
+ """Return the expected value from the file if it exists, or the given default."""
+
def get_path_according_to_suffix() -> Path:
path = Path(pyproject_toml_path)
return path.parent / f"{path.stem}.{suffix}"