summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-04 23:21:02 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-05 15:08:27 +0200
commit4d729a0bb63b6269a4667645008dde8762414769 (patch)
treed7682a47775b7e8a914c3e6de21c9b8983f51976
parenta51786a9a2e98af61e952aaf6b0cb88780866f5b (diff)
downloadpylint-git-4d729a0bb63b6269a4667645008dde8762414769.tar.gz
Handle the version in setup.cfg (as well as everything else)
-rw-r--r--setup.cfg3
-rw-r--r--setup.py14
2 files changed, 2 insertions, 15 deletions
diff --git a/setup.cfg b/setup.cfg
index 31c5f24e7..627655f00 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,6 @@
[metadata]
name = pylint
+version = attr: pylint.__version__
license = GPL-2.0-or-later
license_files =
COPYING
@@ -40,8 +41,6 @@ classifiers =
zip_safe = True
packages = find:
python_requires = ~=3.6
-setup_requires =
-
install_requires =
astroid>=2.5.2,<2.7
isort>=4.2.5,<6
diff --git a/setup.py b/setup.py
index 47877d554..7f1a1763c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,4 @@
-# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/master/COPYING
-
-from pathlib import Path
-from typing import Any, Dict
-
from setuptools import setup
-HERE = Path(__file__).parent
-
-__pkginfo__: Dict[str, Any] = {}
-with open(HERE / "pylint/__pkginfo__.py", encoding="UTF-8") as f:
- exec(f.read(), __pkginfo__) # pylint: disable=exec-used
-
if __name__ == "__main__":
- setup(version=__pkginfo__["__version__"])
+ setup()