summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-04 14:47:46 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-04 22:46:59 +0200
commitb71016cc4c8a6cd61796b5d07323232d803ff7bb (patch)
tree7f44c7373d0fa2291c733e603dc23ab332e35a37
parentb6fd4dc255bc18309afd3e9b125e761abaac8676 (diff)
downloadpylint-git-b71016cc4c8a6cd61796b5d07323232d803ff7bb.tar.gz
Remove outdated Makefile from the repository
-rw-r--r--Makefile73
1 files changed, 0 insertions, 73 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index 37359c438..000000000
--- a/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# Makefile for handling various tasks of Pylint sources
-PYVE=pyve
-PIP=$(PYVE)/bin/pip
-TOX=$(PYVE)/bin/tox
-
-VERSION=$(shell PYTHONPATH=. python -c "from pylint.__pkginfo__ import version; print(version)")
-
-PKG_SDIST=dist/pylint-$(VERSION).tar.gz
-PKG_DEB=../pylint_$(VERSION)-1_all.deb
-
-# this is default target, it should always be first in this Makefile
-help:
- @echo "Please use \`make <target>' where <target> is one of"
- @echo " tests to run whole test suit of PyLint"
- @echo " docs to generate all docs including man pages and exemplary pylintrc"
- @echo " deb to build debian .deb package (it works only on Debian based Linux distros)"
- @echo " sdist to build source .tar.gz package"
- @echo " lint to check Pylint sources with itself"
- @echo " all to run all targets"
-
-
-$(PIP):
- virtualenv $(PYVE)
-
-$(TOX): $(PIP)
- $(PIP) install tox~=2.0
-
-
-ifdef TOXENV
-toxparams?=-e $(TOXENV)
-endif
-
-tests: $(TOX)
- $(TOX) $(toxparams)
-
-docs: $(PIP)
- $(PIP) install .
- $(PIP) install Sphinx
- $(PIP) install python-docs-theme
- . $(PYVE)/bin/activate; make all -C doc
-
-deb: $(PKG_DEB)
-$(PKG_DEB): /usr/bin/debuild /usr/bin/dh_pysupport
- if [ -n "$$SUBVERSION" ]; then sed -i -e "0,/pylint (\(.*\))/s//pylint (\1.$${SUBVERSION})/" debian/changelog; fi
- debuild -b -us -uc
-
-sdist: $(PKG_SDIST)
-$(PKG_SDIST):
- python setup.py sdist
-
-lint: $(PIP)
- $(PIP) install .
- $(PYVE)/bin/pylint lint/__init__.py || true # for now ignore errors
-
-clean:
- rm -rf $(PYVE)
- rm -rf .tox
- rm -rf dist
- rm -rf build
- make clean -C doc
- rm -rf $(PKG_DEB) ../pylint_*.changes ../pylint_*.build
- debuild clean || true
-
-
-/usr/bin/debuild:
- sudo apt-get -y --force-yes install devscripts
-
-/usr/bin/dh_pysupport:
- sudo apt-get -y --force-yes install python-support
-
-all: clean lint tests docs sdist deb
-
-.PHONY: help tests docs deb sdist lint clean all