summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2018-06-04 10:35:34 -0700
committerClaudiu Popa <pcmanticore@gmail.com>2018-06-04 10:38:11 -0700
commitbd8cd3f5300042a60da0e91cfb3228d5bd0b5108 (patch)
tree237f20a3f604d01e872d3ee32dbf1d2bf3598b24
parent3306437d7b0dcb113bc80d2dae2aa5a36b830110 (diff)
downloadpylint-git-bd8cd3f5300042a60da0e91cfb3228d5bd0b5108.tar.gz
Build the documentation with tox
-rw-r--r--doc/development_guide/documentation.rst17
-rw-r--r--tox.ini15
2 files changed, 17 insertions, 15 deletions
diff --git a/doc/development_guide/documentation.rst b/doc/development_guide/documentation.rst
index 4e09fcf63..5b175460f 100644
--- a/doc/development_guide/documentation.rst
+++ b/doc/development_guide/documentation.rst
@@ -3,19 +3,6 @@
Building the documentation
==============
-When you would want to build the documentation for your self, you certainly can. Here's how...
-
-The bare minimum
-----------------
-
-.. sourcecode:: bash
-
- $ python3 -m virtualenv venv
- $ . venv/bin/activate
- $ pip install Sphinx
- $ git clone https://github.com/PyCQA/pylint
- $ cd pylint
- $ python3 setup.py install
- $ cd doc
- $ make html
+We use **tox** for building the documentation::
+ $ tox -e docs
diff --git a/tox.ini b/tox.ini
index 06532e4b9..2f2cf0bff 100644
--- a/tox.ini
+++ b/tox.ini
@@ -55,3 +55,18 @@ skip_install = true
commands =
python {envsitepackagesdir}/coverage erase
changedir = {toxinidir}
+
+[testenv:docs]
+skipsdist = True
+usedevelop = True
+changedir = doc/
+whitelist_externals = rm
+deps =
+ sphinx
+
+commands =
+ rm -f features.rst
+ python ./exts/pylint_features.py
+ rm -f extensions.rst
+ python ./exts/pylint_extensions.py
+ sphinx-build -b html -d _build/doctrees . _build/html