summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-08-23 21:45:45 +0200
committerGitHub <noreply@github.com>2022-08-23 21:45:45 +0200
commitdcd2b17f34700ed5acd56a2d100c4c2c95ce9efa (patch)
tree28edf536a9d345552df314082b56a02d7296e5ea
parentc18c9a7de1154cdf9867fe830efc8e20c71e5634 (diff)
downloadpylint-git-dcd2b17f34700ed5acd56a2d100c4c2c95ce9efa.tar.gz
Upgrade astroid version following 2.12.3 release (#7344)
-rw-r--r--.github/workflows/changelog.yml2
-rw-r--r--.github/workflows/checks.yaml2
-rw-r--r--.github/workflows/primer-test.yaml2
-rw-r--r--.github/workflows/primer_comment.yaml2
-rw-r--r--.github/workflows/primer_run_main.yaml2
-rw-r--r--.github/workflows/primer_run_pr.yaml2
-rw-r--r--.github/workflows/tests.yaml2
-rw-r--r--pyproject.toml2
-rw-r--r--requirements_test_min.txt2
9 files changed, 9 insertions, 9 deletions
diff --git a/.github/workflows/changelog.yml b/.github/workflows/changelog.yml
index 6a92b403e..cf9ad8816 100644
--- a/.github/workflows/changelog.yml
+++ b/.github/workflows/changelog.yml
@@ -6,7 +6,7 @@ on:
env:
# Also change CACHE_VERSION in the other workflows
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
DEFAULT_PYTHON: "3.10"
jobs:
diff --git a/.github/workflows/checks.yaml b/.github/workflows/checks.yaml
index c701bfc86..9d08870e3 100644
--- a/.github/workflows/checks.yaml
+++ b/.github/workflows/checks.yaml
@@ -8,7 +8,7 @@ on:
pull_request: ~
env:
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
DEFAULT_PYTHON: "3.10"
PRE_COMMIT_CACHE: ~/.cache/pre-commit
diff --git a/.github/workflows/primer-test.yaml b/.github/workflows/primer-test.yaml
index 29f3c67a8..219a24b93 100644
--- a/.github/workflows/primer-test.yaml
+++ b/.github/workflows/primer-test.yaml
@@ -13,7 +13,7 @@ on:
- ".github/workflows/primer-test.yaml"
env:
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
concurrency:
group: ${{ github.workflow }}-${{ github.event.pull_request.number || github.ref }}
diff --git a/.github/workflows/primer_comment.yaml b/.github/workflows/primer_comment.yaml
index 651437e44..44113dd93 100644
--- a/.github/workflows/primer_comment.yaml
+++ b/.github/workflows/primer_comment.yaml
@@ -14,7 +14,7 @@ on:
env:
# This needs to be the SAME as in the Main and PR job
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
permissions:
contents: read
diff --git a/.github/workflows/primer_run_main.yaml b/.github/workflows/primer_run_main.yaml
index 8952199d5..2858f92de 100644
--- a/.github/workflows/primer_run_main.yaml
+++ b/.github/workflows/primer_run_main.yaml
@@ -16,7 +16,7 @@ concurrency:
env:
# This needs to be the SAME as in the PR and comment job
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
jobs:
run-primer:
diff --git a/.github/workflows/primer_run_pr.yaml b/.github/workflows/primer_run_pr.yaml
index 76419c765..ddac4e481 100644
--- a/.github/workflows/primer_run_pr.yaml
+++ b/.github/workflows/primer_run_pr.yaml
@@ -25,7 +25,7 @@ concurrency:
env:
# This needs to be the SAME as in the Main and comment job
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
jobs:
run-primer:
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index deebb69a7..4c126ad58 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -10,7 +10,7 @@ on:
- doc/data/messages/**
env:
- CACHE_VERSION: 20
+ CACHE_VERSION: 21
jobs:
tests-linux:
diff --git a/pyproject.toml b/pyproject.toml
index 3980af33c..2d7a9ecde 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -37,7 +37,7 @@ dependencies = [
# Also upgrade requirements_test_min.txt if you are bumping astroid.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.12.2,<=2.14.0-dev0",
+ "astroid>=2.12.3,<=2.14.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 8202b4d77..ddc85297b 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,6 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.12.2 # Pinned to a specific version for tests
+astroid==2.12.3 # Pinned to a specific version for tests
typing-extensions~=4.3
pytest~=7.1
pytest-benchmark~=3.4