summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Tosi <sandro.tosi@gmail.com>2015-03-01 12:49:09 +0000
committerSandro Tosi <sandro.tosi@gmail.com>2015-03-01 12:49:09 +0000
commit5989e64719c56bffd0231fd8220124f8e7586b67 (patch)
tree02784e2652f311b2f23335f064dac177588865c8
parent37e6b5c9c2dba47d2845d5f69557fabaee2e9e55 (diff)
downloadpylint-git-5989e64719c56bffd0231fd8220124f8e7586b67.tar.gz
Make the doc buildable using the current checkout
Passing the PYTHONPATH from the command line, and setting PATH to the built script, this change will make it possible to use the built code used instead of the system-wide installation to build the documentation. Usage example: PATH=./build/scripts-2.7:$PATH make -C doc html PYTHONPATH=./build/lib
-rw-r--r--doc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/Makefile b/doc/Makefile
index d483f6362..2cd7f7e5e 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -6,6 +6,7 @@ SPHINXOPTS =
SPHINXBUILD = sphinx-build
PAPER =
BUILDDIR = _build
+PYTHONPATH =
# Internal variables.
PAPEROPT_a4 = -D latex_paper_size=a4
@@ -138,7 +139,7 @@ features:
echo "" >> features.rst
echo ".. generated by pylint --full-documentation" >> features.rst
echo "" >> features.rst
- pylint --full-documentation >> features.rst
+ PYTHONPATH=$(PYTHONPATH) pylint --full-documentation >> features.rst
gen-examples:
chmod u+w ../examples/pylintrc