summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2017-12-01 11:35:19 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2017-12-11 09:39:49 +0100
commitb35166f35b0be1aa85ad0789ab265e655dd6c1e7 (patch)
treec09e8a427dec03a0cef82ba7da57389661ccc39a
parentbf1aa0c6bbdbc64c1da01f43c564aad3984468e0 (diff)
downloadpylint-git-b35166f35b0be1aa85ad0789ab265e655dd6c1e7.tar.gz
Drop support for EOL Python 3.3
-rw-r--r--.travis.yml3
-rw-r--r--appveyor.yml3
-rw-r--r--doc/faq.rst2
-rw-r--r--pylint/__pkginfo__.py1
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
6 files changed, 3 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index bbc3d4978..e9292e1cf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,9 +7,6 @@ matrix:
env: TOXENV=py27
- python: 2.7.6
env: TOXENV=py27
- # This is used by Ubuntu Trusty
- - python: 3.3
- env: TOXENV=py33
- python: 3.4
env: TOXENV=py34
- python: 3.5-dev
diff --git a/appveyor.yml b/appveyor.yml
index 9a876e705..fd452db7c 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -7,9 +7,6 @@ environment:
- PYTHON: "C:\\Python27"
TOXENV: "py27"
- - PYTHON: "C:\\Python33"
- TOXENV: "py33"
-
- PYTHON: "C:\\Python34"
TOXENV: "py34"
diff --git a/doc/faq.rst b/doc/faq.rst
index 0c65bf66f..e99328ad3 100644
--- a/doc/faq.rst
+++ b/doc/faq.rst
@@ -50,7 +50,7 @@ it is also working on PyPy.
2.4 What versions of Python is Pylint supporting?
--------------------------------------------------
-Since Pylint 1.4, we support only Python 2.7+ and Python 3.3+. If code
+Since Pylint 1.8, we support only Python 2.7 and Python 3.4+. If code
uses new Python 3.6 syntax, minimal required version is Pylint 1.7.
Using this strategy really helps in maintaining a code base compatible
diff --git a/pylint/__pkginfo__.py b/pylint/__pkginfo__.py
index e078f4349..1842025d8 100644
--- a/pylint/__pkginfo__.py
+++ b/pylint/__pkginfo__.py
@@ -69,7 +69,6 @@ classifiers = ['Development Status :: 4 - Beta',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
diff --git a/setup.py b/setup.py
index eedb826a5..fc771be12 100644
--- a/setup.py
+++ b/setup.py
@@ -160,7 +160,7 @@ def install(**kwargs):
cmdclass=cmdclass,
extras_require=extras_require,
test_suite='test',
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
setup_requires=['pytest-runner'],
tests_require=['pytest'],
**kwargs)
diff --git a/tox.ini b/tox.ini
index 1f1261325..24838a248 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py33, py34, py35, py36, pypy, jython, pylint
+envlist = py27, py34, py35, py36, pypy, jython, pylint
skip_missing_interpreters = true
[testenv:pylint]