summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:12:12 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:12:12 +0200
commit8104d137e0a3baefa1d7d1703adb998029b3e7a7 (patch)
treef8b6cb3d98e859f364428b15efe13cad9e351cad
parent57595931ebe4d13ee34e9580fef9177ae293b681 (diff)
downloadpylint-git-8104d137e0a3baefa1d7d1703adb998029b3e7a7.tar.gz
Another fix for generating docs from Makefile - added install sphinx.
--HG-- branch : make
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 83fb5b812..cf6627db3 100644
--- a/Makefile
+++ b/Makefile
@@ -28,10 +28,9 @@ tests: $(TOX)
$(TOX) $(toxparams)
docs: $(PIP)
- rm -f /tmp/pylint
- ln -s -f $(CURDIR) /tmp/pylint
$(PIP) install .
- PYTHONPATH=/tmp PATH=$(CURDIR)/pyve/bin:$(PATH) make all -C doc
+ $(PIP) install Sphinx
+ . pyve/bin/activate; make all -C doc
deb:
debuild -b -us -uc
@@ -43,7 +42,6 @@ lint: $(PIP)
clean:
rm -rf $(PYVE)
rm -rf .tox
- rm -rf /tmp/pylint1 /tmp/pylint2
make clean -C doc
debuild clean