summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-08-27 17:07:18 +0200
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-08-27 17:07:18 +0200
commitd877066a07a013e36b089c25af3f9b41f838271d (patch)
tree37e5bb9d863c1403ee802c8256e23592fa81389d
parentaf4eacb2adbb8232e52e138230fae0c5990d431d (diff)
downloadpylint-git-d877066a07a013e36b089c25af3f9b41f838271d.tar.gz
tries to get to compile on ubuntupylint-version-0.18.1
-rwxr-xr-xdebian.hardy/rules79
-rwxr-xr-xdebian.intrepid/rules79
-rwxr-xr-xdebian.jaunty/rules79
-rwxr-xr-xdebian.lenny/rules79
4 files changed, 316 insertions, 0 deletions
diff --git a/debian.hardy/rules b/debian.hardy/rules
new file mode 100755
index 000000000..81b90c375
--- /dev/null
+++ b/debian.hardy/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ NO_SETUPTOOLS=1 python setup.py -q build
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ find . -name "*.pyc" -delete
+
+ rm -rf build
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/pylint \
+
+
+ rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
+
+ # fixes shebangs
+ for exec in pylint pylint-gui symilar ; do \
+ if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
+ sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
+ fi ; \
+ chmod a+x debian/pylint/usr/bin/$$exec; \
+ done
+
+ install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
+
+ # install tests
+ #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i
+ dh_installman -i
+ dh_installemacsen
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.intrepid/rules b/debian.intrepid/rules
new file mode 100755
index 000000000..81b90c375
--- /dev/null
+++ b/debian.intrepid/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ NO_SETUPTOOLS=1 python setup.py -q build
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ find . -name "*.pyc" -delete
+
+ rm -rf build
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/pylint \
+
+
+ rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
+
+ # fixes shebangs
+ for exec in pylint pylint-gui symilar ; do \
+ if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
+ sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
+ fi ; \
+ chmod a+x debian/pylint/usr/bin/$$exec; \
+ done
+
+ install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
+
+ # install tests
+ #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i
+ dh_installman -i
+ dh_installemacsen
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.jaunty/rules b/debian.jaunty/rules
new file mode 100755
index 000000000..81b90c375
--- /dev/null
+++ b/debian.jaunty/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ NO_SETUPTOOLS=1 python setup.py -q build
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ find . -name "*.pyc" -delete
+
+ rm -rf build
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/pylint \
+
+
+ rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
+
+ # fixes shebangs
+ for exec in pylint pylint-gui symilar ; do \
+ if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
+ sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
+ fi ; \
+ chmod a+x debian/pylint/usr/bin/$$exec; \
+ done
+
+ install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
+
+ # install tests
+ #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i
+ dh_installman -i
+ dh_installemacsen
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.lenny/rules b/debian.lenny/rules
new file mode 100755
index 000000000..81b90c375
--- /dev/null
+++ b/debian.lenny/rules
@@ -0,0 +1,79 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ NO_SETUPTOOLS=1 python setup.py -q build
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ find . -name "*.pyc" -delete
+
+ rm -rf build
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/pylint \
+
+
+ rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
+
+ # fixes shebangs
+ for exec in pylint pylint-gui symilar ; do \
+ if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
+ sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
+ fi ; \
+ chmod a+x debian/pylint/usr/bin/$$exec; \
+ done
+
+ install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
+
+ # install tests
+ #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i
+ dh_installman -i
+ dh_installemacsen
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch