summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmile Anclin <emile.anclin@logilab.fr>2010-11-22 15:16:48 +0100
committerEmile Anclin <emile.anclin@logilab.fr>2010-11-22 15:16:48 +0100
commit9e71dd9fae6fe9ce0e1d779d45fb7c45adf57633 (patch)
tree744f90c2e0352d1472f8205e85bedc25b41356fa
parent5164d45df2523843a00410a08a351bbeee69e8ce (diff)
parent22f3f75cc80d8bb5f6c488dd6484f907d66f6243 (diff)
downloadpylint-git-9e71dd9fae6fe9ce0e1d779d45fb7c45adf57633.tar.gz
merge
-rw-r--r--MANIFEST.in1
-rw-r--r--__pkginfo__.py1
-rw-r--r--debian.py3k/control4
-rwxr-xr-xdebian.py3k/rules20
-rw-r--r--setup.py6
5 files changed, 24 insertions, 8 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 2fcee65dc..f3aab910d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,6 +1,7 @@
include ChangeLog
include COPYING
include DEPENDS
+include README*
include bin/*
include examples/*
include elisp/*
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 4b0edcb51..b4442f5d0 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -24,6 +24,7 @@ version = '.'.join([str(num) for num in numversion])
install_requires = ['logilab-common >= 0.53.0', 'logilab-astng >= 0.21.0']
license = 'GPL'
+copyright = 'Logilab S.A.'
description = "python code static checker"
web = "http://www.logilab.org/project/%s" % distname
ftp = "ftp://ftp.logilab.org/pub/%s" % modname
diff --git a/debian.py3k/control b/debian.py3k/control
index 2ac71a23b..82393f736 100644
--- a/debian.py3k/control
+++ b/debian.py3k/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>,
Sandro Tosi <morph@debian.org>, Julien Jehannet <julien.jehannet@logilab.fr>
-Build-Depends: debhelper (>= 7.0.50~), python3-all
+Build-Depends: debhelper (>= 7.0.50~), python3-all, python3-logilab-common, python3-logilab-astng
Standards-Version: 3.9.1
Homepage: http://www.logilab.org/project/pylint
Vcs-Hg: http://hg.logilab.org/pylint
@@ -12,7 +12,7 @@ Vcs-Browser: http://hg.logilab.org/pylint
Package: pylint3
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.22)
+Depends: ${python:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.21)
Recommends: python3-tk
XB-Python-Version: ${python:Versions}
Description: python code static checker and UML diagram generator
diff --git a/debian.py3k/rules b/debian.py3k/rules
index b5ea1a7bc..c608f8570 100755
--- a/debian.py3k/rules
+++ b/debian.py3k/rules
@@ -5,30 +5,44 @@
# adapted by Logilab for automatic generation by debianize
# (part of the devtools project, http://www.logilab.org/projects/devtools)
#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+# Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE).
# http://www.logilab.fr/ -- mailto:contact@logilab.fr
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
PACKAGE:=$(shell grep Package debian/control | cut -d ' ' -f2)
+PYDEF:=$(shell py3versions -dv)
include /usr/share/python3/python.mk
%:
dh --with python3 $@
+override_dh_auto_build:
+ # python module build
+ NO_SETUPTOOLS=1 python3 setup.py -q build --build-purelib $(CURDIR)/build/lib
+
override_dh_install:
NO_SETUPTOOLS=1 python3 setup.py -q install --no-compile \
--root=$(CURDIR)/debian/$(PACKAGE)/ \
${py_setup_install_args}
- find $(CURDIR)/debian/$(PACKAGE)/usr/lib/python*/*-packages/ ! -path "*/test/*py" -name "*py" -exec 2to3-3.1 -wn {} \;
+ find $(CURDIR)/debian/$(PACKAGE)/usr/lib/python*/*-packages/ ! -path "*/test/*py" -name "*py" -exec 2to3-$(PYDEF) -wn {} \;
+ # rename executables
for executable in pylint pylint-gui symilar epylint pyreverse ; do \
new_exec="$$executable"3; \
- mv -v $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$new_exec; \
+ mv $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$new_exec; \
done
# remove test directory
rm -rf debian/$(PACKAGE)/usr/lib/python*/*-packages/pylint/test
+ # generate pylint man page automatically (only when sources are py3k compatible)
+ PYTHONPATH=debian/$(PACKAGE)/usr/lib/python3/dist-packages python3 $(CURDIR)/bin/pylint --generate-man > $(CURDIR)/man/pylint.1
+ # rename and install man pages
+ for manpage in man/* ; do \
+ new_manpage="$(shell basename ${manpage} .1)"3.1; \
+ mv $$manpage $$new_manpage; \
+ done
+ dh_installman man/*
override_dh_installdocs:
dh_installdocs README*
diff --git a/setup.py b/setup.py
index bbf183af2..759072fdc 100644
--- a/setup.py
+++ b/setup.py
@@ -38,13 +38,13 @@ except ImportError:
from distutils.command import install_lib
USE_SETUPTOOLS = 0
-
sys.modules.pop('__pkginfo__', None)
+# import optional features
+__pkginfo__ = __import__("__pkginfo__")
# import required features
from __pkginfo__ import modname, version, license, description, \
web, author, author_email
-# import optional features
-import __pkginfo__
+
distname = getattr(__pkginfo__, 'distname', modname)
scripts = getattr(__pkginfo__, 'scripts', [])
data_files = getattr(__pkginfo__, 'data_files', None)