summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-09-17 18:58:30 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-09-19 16:19:58 +0200
commit38e278401a66218fba26308fbce56740761a2003 (patch)
tree7b99eb954ff039bc0ecf881858ddbc002cb05e83
parentf5e168e867799013fb380aa9fe8a0c1516a651c8 (diff)
downloadpylint-git-38e278401a66218fba26308fbce56740761a2003.tar.gz
Bump astroid to 2.12.10
-rw-r--r--.github/workflows/changelog.yml2
-rw-r--r--.github/workflows/checks.yaml2
-rw-r--r--.github/workflows/primer-test.yaml2
-rw-r--r--.github/workflows/primer_comment.yaml2
-rw-r--r--.github/workflows/primer_run_main.yaml2
-rw-r--r--.github/workflows/primer_run_pr.yaml2
-rw-r--r--.github/workflows/tests.yaml2
-rw-r--r--pyproject.toml5
-rw-r--r--requirements_test_min.txt3
9 files changed, 12 insertions, 10 deletions
diff --git a/.github/workflows/changelog.yml b/.github/workflows/changelog.yml
index 6e5d6f6e3..a11bfe1cb 100644
--- a/.github/workflows/changelog.yml
+++ b/.github/workflows/changelog.yml
@@ -6,7 +6,7 @@ on:
env:
# Also change CACHE_VERSION in the other workflows
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
DEFAULT_PYTHON: "3.10"
jobs:
diff --git a/.github/workflows/checks.yaml b/.github/workflows/checks.yaml
index a73594185..1b928c333 100644
--- a/.github/workflows/checks.yaml
+++ b/.github/workflows/checks.yaml
@@ -8,7 +8,7 @@ on:
pull_request: ~
env:
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
DEFAULT_PYTHON: "3.10"
PRE_COMMIT_CACHE: ~/.cache/pre-commit
diff --git a/.github/workflows/primer-test.yaml b/.github/workflows/primer-test.yaml
index 0f81b7ee1..e1403a1d3 100644
--- a/.github/workflows/primer-test.yaml
+++ b/.github/workflows/primer-test.yaml
@@ -13,7 +13,7 @@ on:
- ".github/workflows/primer-test.yaml"
env:
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
concurrency:
group: ${{ github.workflow }}-${{ github.event.pull_request.number || github.ref }}
diff --git a/.github/workflows/primer_comment.yaml b/.github/workflows/primer_comment.yaml
index 02677d410..537931171 100644
--- a/.github/workflows/primer_comment.yaml
+++ b/.github/workflows/primer_comment.yaml
@@ -14,7 +14,7 @@ on:
env:
# This needs to be the SAME as in the Main and PR job
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
permissions:
contents: read
diff --git a/.github/workflows/primer_run_main.yaml b/.github/workflows/primer_run_main.yaml
index 1214057f0..56f08f677 100644
--- a/.github/workflows/primer_run_main.yaml
+++ b/.github/workflows/primer_run_main.yaml
@@ -16,7 +16,7 @@ concurrency:
env:
# This needs to be the SAME as in the PR and comment job
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
jobs:
run-primer:
diff --git a/.github/workflows/primer_run_pr.yaml b/.github/workflows/primer_run_pr.yaml
index 50c6454b1..7fa785ce2 100644
--- a/.github/workflows/primer_run_pr.yaml
+++ b/.github/workflows/primer_run_pr.yaml
@@ -25,7 +25,7 @@ concurrency:
env:
# This needs to be the SAME as in the Main and comment job
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
jobs:
run-primer:
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index e07f6a903..13a720fa5 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -10,7 +10,7 @@ on:
- doc/data/messages/**
env:
- CACHE_VERSION: 26
+ CACHE_VERSION: 27
jobs:
tests-linux:
diff --git a/pyproject.toml b/pyproject.toml
index 01a284210..5950fdffd 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -34,10 +34,11 @@ requires-python = ">=3.7.2"
dependencies = [
"dill>=0.2",
"platformdirs>=2.2.0",
- # Also upgrade requirements_test_min.txt if you are bumping astroid.
+ # Also upgrade requirements_test_min.txt and all the CACHE_VERSION in
+ # github actions if you are bumping astroid.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.12.9,<=2.14.0-dev0",
+ "astroid>=2.12.10,<=2.14.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 800d85755..3c917bd87 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,7 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.12.9 # Pinned to a specific version for tests
+# You need to increment the CACHE_VERSION in github actions too
+astroid==2.12.10 # Pinned to a specific version for tests
typing-extensions~=4.3
pytest~=7.1
pytest-benchmark~=3.4