summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-10-10 14:07:37 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-10-10 15:13:15 +0200
commit07f484f4887fab95a15c96e679fc9410a08746cc (patch)
tree0b1301c28cf13f0951ad67f0ea8e52e9d77788de
parentfa63d9beb5e0b0e7e93207e7e672d9eac9732d6a (diff)
downloadpylint-git-07f484f4887fab95a15c96e679fc9410a08746cc.tar.gz
Upgrade astroid version following 2.12.11 release
-rw-r--r--.github/workflows/changelog.yml2
-rw-r--r--.github/workflows/checks.yaml2
-rw-r--r--.github/workflows/primer-test.yaml2
-rw-r--r--.github/workflows/primer_comment.yaml2
-rw-r--r--.github/workflows/primer_run_main.yaml2
-rw-r--r--.github/workflows/primer_run_pr.yaml2
-rw-r--r--.github/workflows/tests.yaml2
-rw-r--r--pyproject.toml2
-rw-r--r--requirements_test_min.txt2
9 files changed, 9 insertions, 9 deletions
diff --git a/.github/workflows/changelog.yml b/.github/workflows/changelog.yml
index a11bfe1cb..730f3dd08 100644
--- a/.github/workflows/changelog.yml
+++ b/.github/workflows/changelog.yml
@@ -6,7 +6,7 @@ on:
env:
# Also change CACHE_VERSION in the other workflows
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
DEFAULT_PYTHON: "3.10"
jobs:
diff --git a/.github/workflows/checks.yaml b/.github/workflows/checks.yaml
index 1b928c333..6cdca8fda 100644
--- a/.github/workflows/checks.yaml
+++ b/.github/workflows/checks.yaml
@@ -8,7 +8,7 @@ on:
pull_request: ~
env:
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
DEFAULT_PYTHON: "3.10"
PRE_COMMIT_CACHE: ~/.cache/pre-commit
diff --git a/.github/workflows/primer-test.yaml b/.github/workflows/primer-test.yaml
index e1403a1d3..a865b1875 100644
--- a/.github/workflows/primer-test.yaml
+++ b/.github/workflows/primer-test.yaml
@@ -13,7 +13,7 @@ on:
- ".github/workflows/primer-test.yaml"
env:
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
concurrency:
group: ${{ github.workflow }}-${{ github.event.pull_request.number || github.ref }}
diff --git a/.github/workflows/primer_comment.yaml b/.github/workflows/primer_comment.yaml
index 537931171..a15c7aea3 100644
--- a/.github/workflows/primer_comment.yaml
+++ b/.github/workflows/primer_comment.yaml
@@ -14,7 +14,7 @@ on:
env:
# This needs to be the SAME as in the Main and PR job
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
permissions:
contents: read
diff --git a/.github/workflows/primer_run_main.yaml b/.github/workflows/primer_run_main.yaml
index 56f08f677..7b8609a6f 100644
--- a/.github/workflows/primer_run_main.yaml
+++ b/.github/workflows/primer_run_main.yaml
@@ -16,7 +16,7 @@ concurrency:
env:
# This needs to be the SAME as in the PR and comment job
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
jobs:
run-primer:
diff --git a/.github/workflows/primer_run_pr.yaml b/.github/workflows/primer_run_pr.yaml
index 7fa785ce2..22ba26dd5 100644
--- a/.github/workflows/primer_run_pr.yaml
+++ b/.github/workflows/primer_run_pr.yaml
@@ -25,7 +25,7 @@ concurrency:
env:
# This needs to be the SAME as in the Main and comment job
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
jobs:
run-primer:
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index 13a720fa5..03643f90d 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -10,7 +10,7 @@ on:
- doc/data/messages/**
env:
- CACHE_VERSION: 27
+ CACHE_VERSION: 28
jobs:
tests-linux:
diff --git a/pyproject.toml b/pyproject.toml
index 5950fdffd..b6a494af8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,7 +38,7 @@ dependencies = [
# github actions if you are bumping astroid.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
# see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.12.10,<=2.14.0-dev0",
+ "astroid>=2.12.11,<=2.14.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index 3c917bd87..6b2dcdf2a 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,7 +1,7 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
# You need to increment the CACHE_VERSION in github actions too
-astroid==2.12.10 # Pinned to a specific version for tests
+astroid==2.12.11 # Pinned to a specific version for tests
typing-extensions~=4.3
pytest~=7.1
pytest-benchmark~=3.4