summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2023-04-03 14:11:54 +0200
committerGitHub <noreply@github.com>2023-04-03 14:11:54 +0200
commit574edc3da35a750ef1ffe2bc4167acdb9e9bd357 (patch)
tree817e03cd1cd286155515ebb2cfd67c015666fcd9
parent6dda042008e69419cdf52192ab699d97e48b05e3 (diff)
downloadpylint-git-574edc3da35a750ef1ffe2bc4167acdb9e9bd357.tar.gz
Upgrade astroid to 2.15.2 (#8530) (#8532)
-rw-r--r--pyproject.toml4
-rw-r--r--requirements_test_min.txt2
2 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 333d2856e..559341011 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,8 +38,8 @@ dependencies = [
"platformdirs>=2.2.0",
# Also upgrade requirements_test_min.txt.
# Pinned to dev of second minor update to allow editable installs and fix primer issues,
- # see https://github.com/PyCQA/astroid/issues/1341
- "astroid>=2.15.0,<=2.17.0-dev0",
+ # see https://github.com/pylint-dev/astroid/issues/1341
+ "astroid>=2.15.2,<=2.17.0-dev0",
"isort>=4.2.5,<6",
"mccabe>=0.6,<0.8",
"tomli>=1.1.0;python_version<'3.11'",
diff --git a/requirements_test_min.txt b/requirements_test_min.txt
index d3a76f096..08321b54f 100644
--- a/requirements_test_min.txt
+++ b/requirements_test_min.txt
@@ -1,6 +1,6 @@
-e .[testutils,spelling]
# astroid dependency is also defined in pyproject.toml
-astroid==2.15.0 # Pinned to a specific version for tests
+astroid==2.15.2 # Pinned to a specific version for tests
typing-extensions~=4.5
py~=1.11.0
pytest~=7.2