summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-04 21:38:52 +0200
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-04-05 15:08:27 +0200
commitd51110e6cd3ad7a44725f9fe915e0ac8779bffe7 (patch)
tree2ba313d6ea268457b449d59c0e58f4ff86d7a417
parent5962b343fe3791b04d9502ed7e7932a6c2d650b5 (diff)
downloadpylint-git-d51110e6cd3ad7a44725f9fe915e0ac8779bffe7.tar.gz
Use setup.cfg for existing hard coded values
-rw-r--r--.github/workflows/ci.yaml8
-rw-r--r--setup.cfg47
-rw-r--r--setup.py45
3 files changed, 52 insertions, 48 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index aa4684ced..d17ed127e 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -32,7 +32,7 @@ jobs:
id: generate-python-key
run: >-
echo "::set-output name=key::base-venv-${{ env.CACHE_VERSION }}-${{
- hashFiles('pylint/__pkg_info__.py', 'requirements_test.txt', 'setup.py', 'requirements_test_min.txt')
+ hashFiles('pylint/__pkg_info__.py', 'requirements_test.txt', 'setup.py', 'setup.cfg', 'requirements_test_min.txt')
}}"
- name: Restore Python virtual environment
id: cache-venv
@@ -163,7 +163,7 @@ jobs:
run: >-
echo "::set-output name=key::venv-${{ env.CACHE_VERSION }}-${{
hashFiles('pylint/__pkg_info__.py', 'requirements_test.txt', 'setup.py',
- 'requirements_test_min.txt') }}"
+ 'setup.cfg', 'requirements_test_min.txt') }}"
- name: Restore Python virtual environment
id: cache-venv
uses: actions/cache@v2.1.4
@@ -334,7 +334,7 @@ jobs:
id: generate-python-key
run: >-
echo "::set-output name=key::venv-${{ env.CACHE_VERSION }}-${{
- hashFiles('pylint/__pkg_info__.py', 'setup.py', 'requirements_test_min.txt') }}"
+ hashFiles('pylint/__pkg_info__.py', 'setup.py', 'setup.cfg', 'requirements_test_min.txt') }}"
- name: Restore Python virtual environment
id: cache-venv
uses: actions/cache@v2.1.4
@@ -412,7 +412,7 @@ jobs:
id: generate-python-key
run: >-
echo "::set-output name=key::venv-${{ env.CACHE_VERSION }}-${{
- hashFiles('pylint/__pkg_info__.py', 'setup.py', 'requirements_test_min.txt') }}"
+ hashFiles('pylint/__pkg_info__.py', 'setup.py', 'setup.cfg', 'requirements_test_min.txt') }}"
- name: Restore Python virtual environment
id: cache-venv
uses: actions/cache@v2.1.4
diff --git a/setup.cfg b/setup.cfg
index 7eebebf32..e77b64d1c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,50 @@
+[metadata]
+name = pylint
+license = GPL-2.0-or-later
+description = python code static checker
+author = Python Code Quality Authority
+author_email = code-quality@python.org
+url = https://github.com/PyCQA/pylint
+project_urls =
+ What's New=https://pylint.pycqa.org/en/latest/whatsnew/
+classifiers =
+ Development Status :: 6 - Mature
+ Environment :: Console
+ Intended Audience :: Developers
+ License :: OSI Approved :: GNU General Public License (GPL)
+ Operating System :: OS Independent
+ Programming Language :: Python
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3 :: Only
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ Topic :: Software Development :: Debuggers
+ Topic :: Software Development :: Quality Assurance
+ Topic :: Software Development :: Testing
+
+[options]
+packages = find:
+python_requires = ~=3.6
+setup_requires =
+
+install_requires =
+ astroid>=2.5.2,<2.7
+ isort>=4.2.5,<6
+ mccabe>=0.6,<0.7
+ toml>=0.7.1
+ colorama;sys_platform=="win32"
+
+[options.entry_points]
+console_scripts =
+ pylint = pylint:run_pylint
+ epylint = pylint:run_epylint
+ pyreverse = pylint:run_pyreverse
+ symilar = pylint:run_symilar
+
[aliases]
test = pytest
diff --git a/setup.py b/setup.py
index 863e95fe4..189e71e11 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@
from pathlib import Path
from typing import Any, Dict
-from setuptools import find_packages, setup
+from setuptools import setup
HERE = Path(__file__).parent
@@ -33,55 +33,12 @@ for requirement_file in DEV_REQUIREMENTS_FILES:
if __name__ == "__main__":
setup(
- name="pylint",
version=__pkginfo__["__version__"],
- license="GPL-2.0-or-later",
- description="python code static checker",
long_description=long_description,
- author="Python Code Quality Authority",
- author_email="code-quality@python.org",
- url="https://github.com/PyCQA/pylint",
- project_urls={"What's New": "https://pylint.pycqa.org/en/latest/whatsnew/"},
- classifiers=[
- "Development Status :: 6 - Mature",
- "Environment :: Console",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: GNU General Public License (GPL)",
- "Operating System :: OS Independent",
- "Programming Language :: Python",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3 :: Only",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "Topic :: Software Development :: Debuggers",
- "Topic :: Software Development :: Quality Assurance",
- "Topic :: Software Development :: Testing",
- ],
- packages=find_packages(),
- python_requires="~=3.6",
- setup_requires=[],
tests_require=test_requires,
- install_requires=[
- "astroid>=2.5.2,<2.7",
- "isort>=4.2.5,<6",
- "mccabe>=0.6,<0.7",
- "toml>=0.7.1",
- ],
extras_require={
':sys_platform=="win32"': ["colorama"],
"docs": doc_extra_requires,
"dev": dev_extra_requires,
},
- entry_points={
- "console_scripts": [
- "pylint = pylint:run_pylint",
- "epylint = pylint:run_epylint",
- "pyreverse = pylint:run_pyreverse",
- "symilar = pylint:run_symilar",
- ]
- },
)