summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:56:42 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:56:42 +0200
commitb50d6948d668a804731cc9918f35dda0b8fe668e (patch)
treed175d37c67a8d3e3a98e8142abfd4effaae5f8cd /Makefile
parent0f79335e64f9be6e44585ea4d49d406e25384553 (diff)
downloadpylint-git-b50d6948d668a804731cc9918f35dda0b8fe668e.tar.gz
Added missing deps for building deb package.
--HG-- branch : make
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 5002ea12b..66e782240 100644
--- a/Makefile
+++ b/Makefile
@@ -38,7 +38,7 @@ docs: $(PIP)
. $(PYVE)/bin/activate; make all -C doc
deb: $(PKG_DEB)
-$(PKG_DEB): /usr/bin/debuild
+$(PKG_DEB): /usr/bin/debuild /usr/bin/dh_pysupport
debuild -b -us -uc
sdist: $(PKG_SDIST)
@@ -49,18 +49,21 @@ lint: $(PIP)
$(PIP) install .
$(PYVE)/bin/pylint lint.py || true # for now ignore errors
-clean: /usr/bin/debuild
+clean: /usr/bin/debuild /usr/bin/dh_pysupport
rm -rf $(PYVE)
rm -rf .tox
rm -rf dist
rm -rf build
make clean -C doc
debuild clean
- rm -rf $(PKG_DEB)
+ rm -rf $(PKG_DEB) ../pylint_*.changes ../pylint_*.build
/usr/bin/debuild:
sudo apt-get -y --force-yes install devscripts
+/usr/bin/dh_pysupport
+ sudo apt-get -y --force-yes install python-support
+
all: clean lint tests docs sdist deb
.PHONY: help tests docs deb sdist lint clean all