summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2018-08-22 11:15:52 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2018-08-22 11:16:24 +0200
commit10d688ec78b27e52f41d7a061593112cbc596a90 (patch)
tree50b8609e1775c6f91bb433576cf33c6dd1c643cd /README.rst
parent79797e192e3e363ed00beecd803c0bb200faf36e (diff)
downloadpylint-git-10d688ec78b27e52f41d7a061593112cbc596a90.tar.gz
Update the README with some improvements; also fix the line endings
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst173
1 files changed, 92 insertions, 81 deletions
diff --git a/README.rst b/README.rst
index 9b222b3cf..c67bb51ea 100644
--- a/README.rst
+++ b/README.rst
@@ -1,81 +1,92 @@
-
-README for Pylint - http://pylint.pycqa.org/
-============================================
-
-.. image:: https://travis-ci.org/PyCQA/pylint.svg?branch=master
- :target: https://travis-ci.org/PyCQA/pylint
-
-.. image:: https://ci.appveyor.com/api/projects/status/rbvwhakyj1y09atb/branch/master?svg=true
- :alt: AppVeyor Build Status
- :target: https://ci.appveyor.com/project/PCManticore/pylint
-
-.. image:: https://coveralls.io/repos/github/PyCQA/pylint/badge.svg?branch=master
- :target: https://coveralls.io/github/PyCQA/pylint?branch=master
-
-
-.. image:: https://img.shields.io/pypi/v/pylint.svg
- :alt: Pypi Package version
- :target: https://pypi.python.org/pypi/pylint
-
-.. image:: https://readthedocs.org/projects/pylint/badge/?version=latest
- :target: http://pylint.readthedocs.io/en/latest/?badge=latest
- :alt: Documentation Status
-
-Pylint is a Python source code analyzer which looks for programming errors,
-helps enforcing a coding standard and sniffs for some code smells (as defined in
-Martin Fowler's Refactoring book).
-
-Pylint has many rules enabled by default, way too much to silence them all on a
-minimally sized program. It's highly configurable and handle pragmas to control
-it from within your code. Additionally, it is possible to write plugins to add
-your own checks.
-
-It's a free software distributed under the GNU General Public Licence.
-
-Development is hosted on GitHub: https://github.com/PyCQA/pylint/
-
-You can use the code-quality@python.org mailing list to discuss about
-Pylint. Subscribe at https://mail.python.org/mailman/listinfo/code-quality/
-or read the archives at https://mail.python.org/pipermail/code-quality/
-
-Install
--------
-
-Pylint requires astroid package (the later the better).
-
-* https://github.com/PyCQA/astroid
-
-Installation should be as simple as ::
-
- python -m pip install astroid
-
-Pylint requires isort package (the later the better).
-
-* https://github.com/timothycrosley/isort
-
-Installation should be as simple as ::
-
- python -m pip install isort
-
-
-If you want to install from a source distribution, extract the tarball and run
-the following commands ::
-
- python setup.py install
-
-You'll have to install dependencies in a similar way. For debian and
-rpm packages, use your usual tools according to your Linux distribution.
-
-More information about installation and available distribution format
-may be found in the user manual in the *doc* subdirectory.
-
-Documentation
--------------
-
-Look in the doc/ subdirectory or at http://pylint.pycqa.org/
-
-Pylint is shipped with following additional commands:
-
-* pyreverse: an UML diagram generator
-* symilar: an independent similarities checker
-* epylint: Emacs and Flymake compatible Pylint
+
+README for Pylint - http://pylint.pycqa.org/
+============================================
+
+.. image:: https://travis-ci.org/PyCQA/pylint.svg?branch=master
+ :target: https://travis-ci.org/PyCQA/pylint
+
+.. image:: https://ci.appveyor.com/api/projects/status/rbvwhakyj1y09atb/branch/master?svg=true
+ :alt: AppVeyor Build Status
+ :target: https://ci.appveyor.com/project/PCManticore/pylint
+
+.. image:: https://coveralls.io/repos/github/PyCQA/pylint/badge.svg?branch=master
+ :target: https://coveralls.io/github/PyCQA/pylint?branch=master
+
+
+.. image:: https://img.shields.io/pypi/v/pylint.svg
+ :alt: Pypi Package version
+ :target: https://pypi.python.org/pypi/pylint
+
+.. image:: https://readthedocs.org/projects/pylint/badge/?version=latest
+ :target: http://pylint.readthedocs.io/en/latest/?badge=latest
+ :alt: Documentation Status
+
+Pylint is a Python static code analysis tool which looks for programming errors,
+helps enforcing a coding standard, sniffs for code smells and offers simple refactoring
+suggestions.
+
+It's highly configurable, having special pragmas to control its errors and warnings
+from within your code, as well as from an extensive configuration file.
+It is also possible to write your own plugins for adding your own checks or for
+extending pylint in one way or another.
+
+It's a free software distributed under the GNU General Public Licence.
+
+Development is hosted on GitHub: https://github.com/PyCQA/pylint/
+
+You can use the code-quality@python.org mailing list to discuss about
+Pylint. Subscribe at https://mail.python.org/mailman/listinfo/code-quality/
+or read the archives at https://mail.python.org/pipermail/code-quality/
+
+Pull requests are amazing and most welcome.
+
+Install
+-------
+
+Pylint can be simply installed by running::
+
+ pip install pylint
+
+
+If you want to install from a source distribution, extract the tarball and run
+the following command ::
+
+ python setup.py install
+
+
+Do make sure to do the same for astroid, which is used internally by pylint.
+
+For debian and rpm packages, use your usual tools according to your Linux distribution.
+
+More information about installation and available distribution format
+can be found here_.
+
+Documentation
+-------------
+
+The documentation lives at http://pylint.pycqa.org/.
+
+Pylint is shipped with following additional commands:
+
+* pyreverse: an UML diagram generator
+* symilar: an independent similarities checker
+* epylint: Emacs and Flymake compatible Pylint
+
+
+Testing
+-------
+
+We use tox_ for running the test suite. You should be able to install it with::
+
+ pip install tox pytest
+
+
+To run the test suite for a particular Python version, you can do::
+
+ tox -e py27
+
+
+For more detailed information, check the documentation.
+
+.. _here: http://pylint.pycqa.org/en/latest/user_guide/installation.html
+.. _tox: https://tox.readthedocs.io/en/latest/