summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorSteven Myint <git@stevenmyint.com>2015-12-10 18:28:12 -0800
committerSteven Myint <git@stevenmyint.com>2015-12-10 18:28:12 -0800
commit0d295f082656de74512b93cb363cf3bce15e01b1 (patch)
treed1b84d1171638f45ebbe0592a76e1ecd37710948 /README.rst
parent2066c0b6a4d7746aaeee73fb6730993bbbd29598 (diff)
parentdc855ef69f3d6e7441b349b74915454df61a7fed (diff)
downloadpylint-git-0d295f082656de74512b93cb363cf3bce15e01b1.tar.gz
Merge remote-tracking branch 'upstream/master' into patch-1
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst60
1 files changed, 60 insertions, 0 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 000000000..4813dc526
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,60 @@
+
+.. image:: https://drone.io/bitbucket.org/logilab/pylint/status.png
+ :alt: drone.io Build Status
+ :target: https://drone.io/bitbucket.org/logilab/pylint
+
+README for Pylint - http://www.pylint.org/
+==========================================
+
+Pylint is a Python source code analyzer which looks for programming errors,
+helps enforcing a coding standard and sniffs for some code smells (as defined in
+Martin Fowler's Refactoring book).
+
+Pylint has many rules enabled by default, way too much to silence them all on a
+minimally sized program. It's highly configurable and handle pragmas to control
+it from within your code. Additionally, it is possible to write plugins to add
+your own checks.
+
+It's a free software distributed under the GNU Public Licence.
+
+Development is hosted on GitHub: https://github.com/PyCQA/pylint/
+
+You can use the code-quality@python.org mailing list to discuss about
+Pylint. Subscribe at https://mail.python.org/mailman/listinfo/code-quality/
+or read the archives at https://mail.python.org/pipermail/code-quality/
+
+Install
+-------
+
+Pylint requires astroid package (the later the better).
+
+* https://github.com/PyCQA/astroid
+
+Installation should be as simple as ::
+
+ python -m pip install astroid
+
+
+If you want to install from a source distribution, extract the tarball and run
+the following commands ::
+
+ hg update master
+ python setup.py install
+
+You'll have to install dependencies in a similar way. For debian and
+rpm packages, use your usual tools according to your Linux distribution.
+
+More information about installation and available distribution format
+may be found in the user manual in the *doc* subdirectory.
+
+Documentation
+-------------
+
+Look in the doc/ subdirectory or at http://docs.pylint.org
+
+Pylint is shipped with following additional commands:
+
+* pyreverse: an UML diagram generator
+* symilar: an independent similarities checker
+* epylint: Emacs and Flymake compatible Pylint
+* pylint-gui: a graphical interface