summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2015-12-10 17:30:54 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2015-12-10 17:30:54 +0200
commitdc855ef69f3d6e7441b349b74915454df61a7fed (patch)
tree9cfbde196ca9e2ae768ef93734d62d2eb8ad773f /README.rst
parentb7c95a5a88555314ed6c1a94263f85b0b0e27f24 (diff)
downloadpylint-git-dc855ef69f3d6e7441b349b74915454df61a7fed.tar.gz
Change the extension of the README, so it will get rendered by GitHub
Also, removes README.python3, which doesn't provide any extra information that's not already found in the README.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst60
1 files changed, 60 insertions, 0 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 000000000..045318f94
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,60 @@
+
+.. image:: https://drone.io/bitbucket.org/logilab/pylint/status.png
+ :alt: drone.io Build Status
+ :target: https://drone.io/bitbucket.org/logilab/pylint
+
+README for Pylint - http://www.pylint.org/
+==========================================
+
+Pylint is a Python source code analyzer which looks for programming errors,
+helps enforcing a coding standard and sniffs for some code smells (as defined in
+Martin Fowler's Refactoring book).
+
+Pylint has many rules enabled by default, way too much to silence them all on a
+minimally sized program. It's highly configurable and handle pragmas to control
+it from within your code. Additionally, it is possible to write plugins to add
+your own checks.
+
+It's a free software distributed under the GNU Public Licence.
+
+Development is hosted on bitbucket: https://bitbucket.org/logilab/pylint/
+
+You can use the code-quality@python.org mailing list to discuss about
+Pylint. Subscribe at https://mail.python.org/mailman/listinfo/code-quality/
+or read the archives at https://mail.python.org/pipermail/code-quality/
+
+Install
+-------
+
+Pylint requires astroid package (the later the better).
+
+* https://bitbucket.org/logilab/astroid
+
+Installation should be as simple as ::
+
+ python -m pip install astroid
+
+
+If you want to install from a source distribution, extract the tarball and run
+the following commands ::
+
+ hg update master
+ python setup.py install
+
+You'll have to install dependencies in a similar way. For debian and
+rpm packages, use your usual tools according to your Linux distribution.
+
+More information about installation and available distribution format
+may be found in the user manual in the *doc* subdirectory.
+
+Documentation
+-------------
+
+Look in the doc/ subdirectory or at http://docs.pylint.org
+
+Pylint is shipped with following additional commands:
+
+* pyreverse: an UML diagram generator
+* symilar: an independent similarities checker
+* epylint: Emacs and Flymake compatible Pylint
+* pylint-gui: a graphical interface \ No newline at end of file