summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2015-12-16 17:36:35 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2015-12-16 17:36:35 +0200
commit227bf4cbe891c60b9fa1dad5c63e1d2a38e105bf (patch)
treee5829006068f3f33b98d1037b4815f30095a6f2a /appveyor.yml
parent49e1eb38035798d2873fca7db68a1e1ee39ed8e2 (diff)
downloadpylint-git-227bf4cbe891c60b9fa1dad5c63e1d2a38e105bf.tar.gz
Configure appveyor with the same configuration that astroid has.
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml49
1 files changed, 20 insertions, 29 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 7613e62ba..999daa872 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,3 +1,7 @@
+version: '{branch}-{build}'
+build: off
+cache:
+ - 'C:\\tmp'
environment:
matrix:
- PYTHON: "C:\\Python27"
@@ -9,36 +13,23 @@ environment:
- PYTHON: "C:\\Python34"
TOXENV: "py34"
-install:
- - ECHO "Filesystem root:"
- - ps: "ls \"C:/\""
-
- # Install pip when not already installed.
- - "powershell ./appveyor/install.ps1"
-
- # Prepend newly installed Python to the PATH of this build (this cannot be
- # done from inside the powershell script as it would require to restart
- # the parent CMD process).
- - "SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%"
-
- # Check that we have the expected version and architecture for Python
- - "python --version"
- - "python -c \"import struct; print(struct.calcsize('P') * 8)\""
+ - PYTHON: "C:\\Python35"
+ TOXENV: "py35"
- # Install the build dependencies of the project.
- - "pip install tox==1.7.2"
- - "pip install wheel"
-
-build: false
+init:
+ - ps: echo $env:TOXENV
+ - ps: ls C:\Python*
+ - ps: mkdir C:\tmp
+install:
+ - 'powershell ./appveyor/install.ps1'
+ - "python -m pip install tox"
+ - 'python -m pip install wheel'
+ - 'python -m pip --version'
+ - 'python -m tox --version'
test_script:
- - "tox"
-
-after_test:
- # If tests are successful, create a whl package for the project.
- - "python setup.py bdist_wheel bdist_wininst"
- - ps: "ls dist"
+ - 'python -m tox'
-artifacts:
- # Archive the generated wheel package in the ci.appveyor.com build report.
- - path: dist\*
+on_failure:
+ - ps: dir "env:"
+ - ps: get-content .tox\*\log\*