summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2021-02-21 13:27:11 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-02-21 15:36:16 +0100
commit5bed07eba999130b6551acc7c43192d6a8eada43 (patch)
tree09e3a11503bd074363556e8a5fd33fc0e8db7fc4 /setup.py
parenta1e553d3bb07c56ca99c31279f9af104bede0a32 (diff)
downloadpylint-git-5bed07eba999130b6551acc7c43192d6a8eada43.tar.gz
Move from % string formatting syntax to f-string or .format()
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 94198a01a..1b3a3c07c 100644
--- a/setup.py
+++ b/setup.py
@@ -94,7 +94,7 @@ def get_packages(directory, prefix):
if isdir(absfile):
if exists(join(absfile, "__init__.py")):
if prefix:
- result.append("%s.%s" % (prefix, package))
+ result.append(f"{prefix}.{package}")
else:
result.append(package)
result += get_packages(absfile, result[-1])
@@ -159,7 +159,7 @@ def install(**kwargs):
setup_requires=pytest_runner,
tests_require=["pytest", "pytest-benchmark"],
project_urls=project_urls,
- **kwargs
+ **kwargs,
)