diff options
author | Hugo <hugovk@users.noreply.github.com> | 2017-12-01 11:18:13 +0200 |
---|---|---|
committer | Claudiu Popa <pcmanticore@gmail.com> | 2017-12-11 09:39:49 +0100 |
commit | bf1aa0c6bbdbc64c1da01f43c564aad3984468e0 (patch) | |
tree | ee2277f3aa1e9b59a7c2f6958df757da7e934de6 /setup.py | |
parent | 444c878efb48976aa8b91266d42dc2086e6009b1 (diff) | |
download | pylint-git-bf1aa0c6bbdbc64c1da01f43c564aad3984468e0.tar.gz |
Update classifiers and add python_requires
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 1 insertions, 3 deletions
@@ -129,9 +129,6 @@ def install(**kwargs): if USE_SETUPTOOLS: if '--force-manifest' in sys.argv: sys.argv.remove('--force-manifest') - # install-layout option was introduced in 2.5.3-1~exp1 - elif sys.version_info < (2, 5, 4) and '--install-layout=deb' in sys.argv: - sys.argv.remove('--install-layout=deb') packages = [modname] + get_packages(join(base_dir, 'pylint'), modname) if USE_SETUPTOOLS: if install_requires: @@ -163,6 +160,7 @@ def install(**kwargs): cmdclass=cmdclass, extras_require=extras_require, test_suite='test', + python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*', setup_requires=['pytest-runner'], tests_require=['pytest'], **kwargs) |