diff options
author | Ashley Whetter <ashley@awhetter.co.uk> | 2019-06-14 22:28:42 -0700 |
---|---|---|
committer | Claudiu Popa <pcmanticore@gmail.com> | 2019-06-20 10:02:14 +0200 |
commit | 33b8185a455c1686d038258697bb93005f2441c2 (patch) | |
tree | 4a50ccac775c009436e45803129e428ed694065f /setup.py | |
parent | 7081d91f30728653000bdfc59ea85a3395f96418 (diff) | |
download | pylint-git-33b8185a455c1686d038258697bb93005f2441c2.tar.gz |
Stopped installing tests with package
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 32 |
1 files changed, 1 insertions, 31 deletions
@@ -52,7 +52,6 @@ with open(os.path.join(base_dir, "pylint", "__pkginfo__.py")) as f: exec(f.read(), __pkginfo__) scripts = __pkginfo__.get("scripts", []) data_files = __pkginfo__.get("data_files", None) -include_dirs = __pkginfo__.get("include_dirs", []) ext_modules = __pkginfo__.get("ext_modules", None) install_requires = __pkginfo__.get("install_requires", None) dependency_links = __pkginfo__.get("dependency_links", []) @@ -97,35 +96,6 @@ def _filter_tests(files): return [f for f in files if testdir not in f] -class MyInstallLib(install_lib.install_lib): - """extend install_lib command to handle package __init__.py and - include_dirs variable if necessary - """ - - def run(self): - """overridden from install_lib class""" - install_lib.install_lib.run(self) - # manually install included directories if any - if include_dirs: - for directory in include_dirs: - dest = join(self.install_dir, directory) - if sys.version_info >= (3, 0): - exclude = {"invalid_encoded_data*", "unknown_encoding*"} - else: - exclude = set() - shutil.rmtree(dest, ignore_errors=True) - shutil.copytree( - directory, dest, ignore=shutil.ignore_patterns(*exclude) - ) - - # override this since pip/easy_install attempt to byte compile test data - # files, some of them being syntactically wrong by design, and this scares - # the end-user - def byte_compile(self, files): - files = _filter_tests(files) - install_lib.install_lib.byte_compile(self, files) - - if easy_install_lib: class easy_install(easy_install_lib.easy_install): @@ -156,7 +126,7 @@ def install(**kwargs): ] } kwargs["packages"] = packages - cmdclass = {"install_lib": MyInstallLib, "build_py": build_py} + cmdclass = {"build_py": build_py} if easy_install_lib: cmdclass["easy_install"] = easy_install return setup( |