summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPedro Algarvio <pedro@algarvio.me>2014-11-28 19:09:45 +0000
committerPedro Algarvio <pedro@algarvio.me>2014-11-28 19:09:45 +0000
commitfee62650901a2f444ee7c1537f411f355dfa5dbe (patch)
treeff3641d6888ce74ee6dda65b21964e78d94b2d3e /setup.py
parentbbc2ae9af1893776c2143df253de40d7dca43962 (diff)
downloadpylint-git-fee62650901a2f444ee7c1537f411f355dfa5dbe.tar.gz
New style tuple syntax is only supported on Python >= 2.7
--HG-- branch : hotfix/py26-compat
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b4f8240b8..71fc3b304 100644
--- a/setup.py
+++ b/setup.py
@@ -120,8 +120,8 @@ class MyInstallLib(install_lib.install_lib):
for directory in include_dirs:
dest = join(self.install_dir, base, directory)
if sys.version_info >= (3, 0):
- exclude = {'invalid_encoded_data*',
- 'unknown_encoding*'}
+ exclude = set(['invalid_encoded_data*',
+ 'unkown_encoding*'])
else:
exclude = set()
shutil.rmtree(dest, ignore_errors=True)