summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 22:08:08 -0300
committerRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 22:08:08 -0300
commit486aa114d52afcd5e12f8ef3ec166833326f5005 (patch)
tree8a95131316aa8ca8b080b100b410d35020193e5f /setup.py
parent9383d144f87247dcdb6419ff2c1b70977d0ed656 (diff)
downloadpylint-git-486aa114d52afcd5e12f8ef3ec166833326f5005.tar.gz
code commented and import moved so it won't run when python>2.5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9820c474d..53528333c 100644
--- a/setup.py
+++ b/setup.py
@@ -132,6 +132,9 @@ class MyInstallLib(install_lib.install_lib):
exclude = set()
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
+ # since python2.5's copytree doesn't support the ignore
+ # parameter, the following loop to remove the exclude set
+ # was added
for (dirpath, dirnames, filenames) in os.walk(dest):
for n in filenames:
if n in exclude: