diff options
author | Anthony Sottile <asottile@umich.edu> | 2020-03-19 11:20:05 -0700 |
---|---|---|
committer | Claudiu Popa <pcmanticore@gmail.com> | 2020-03-24 10:27:21 +0100 |
commit | a45505143f89718073b7d06c99d09c05cd0e4108 (patch) | |
tree | b5be3d9c6f8a29ec08af5147702c0f99eb549ebc /setup.py | |
parent | 63bf9dcf39a7dbd86601ef6c6a16eef4768f1e9a (diff) | |
download | pylint-git-a45505143f89718073b7d06c99d09c05cd0e4108.tar.gz |
pyupgrade: automated removal of python2 constructs
using configuration:
```yaml
- repo: https://github.com/asottile/pyupgrade
rev: v2.1.0
hooks:
- id: pyupgrade
args: [--py3-plus, --keep-percent-format]
exclude: ^tests/(extensions/data/|functional/|input/|regrtest_data/)
```
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -1,5 +1,4 @@ #!/usr/bin/env python -# -*- coding: utf-8 -*- # pylint: disable=W0404,W0622,W0613 # Copyright (c) 2006, 2009-2010, 2012-2014 LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr> # Copyright (c) 2010 Julien Jehannet <julien.jehannet@logilab.fr> @@ -62,7 +61,7 @@ else: long_description = "" -needs_pytest = set(['pytest', 'test', 'ptr']).intersection(sys.argv) +needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv) pytest_runner = ['pytest-runner'] if needs_pytest else [] |